ubisoft forums

Quick Suggestions

  • GhostofGrey
    1 posts

    I wanted to explore the map before I got into missions. I came across the mystery about the comb by the water fall , but couldn't interact with woman. So I left and went back to village. Then I had trouble talking to most of the characters since. Restarted game several times to try and start the prodigal prince quest , but know I'm stuck . Had reloaded several times and deleted several save to try and get past this point , be it nothing has worked. I'm stuck at the pier and can't get sig to talk to me.

  • Torusya
    16 posts

    @johnnys_archi Thanks man, I will try. Just feels too bad to waste hours of gameplay and I am afraid I will get stuck somewhere again.

  • Jack.Toff
    1 posts

    After the training with the hidden blade, I have to follow Sigurd. When I do, nothing happens and I am stuck here.

  • cmcreed_43
    5 posts

    I'm in the same boat. Either the game ends for me until a patch, or try the restart after hours and hours of playing. I have the same worry that if I restart, I will hit the same, or another bug, and the restart will all be for nothing...

  • amdo-AK
    7 posts

    @torusya I just saved my old saves online, then I disconnected from the internet and deleted my saves from the storage, reinstalled the game and played from the scratch, rushed only the main missions until I reached England, I connected to the internet, upload my old saves, then boom! It worked! As I already has passed the bugging point!

  • guest-ZRVvJeiF
    6 posts

    @ubi-swaggins omg, it's a few days now without any notice of solution about the problem. We are not your beta testers, show some respect to the people that bought your game.

  • MPZ4584
    1 posts

    Same deal for me on the PS4... Unplayable

  • Beastmod_shod
    1 posts

    Whenever I follow Sigurd down to the docks he talks to me for a little bit and then my whole game corrupts and I've re-download it and still having same issues no matter what gender or what I do leading up to talking with Sigurd or what save I load it just doesn't work

  • wmcbride
    1 posts

    I have the same issue!!!

  • PaulB79
    1 posts

    I seem to have the same problem as everyone else. I walk to the dock with Sigurd, he then just stands there. I am therefore unable to move on with my game. If there is no fix forthcoming I doubt I'll bother restarting from the beginning.

    This is on the xbox series x.

    Looking at the number people with the same problem this is pretty unacceptable by ubisoft.

  • High_LordWolnir
    1 posts

    Same problem for me.

    Ubisoft managed to [censored] my first experience with new gen up.

    I get stuck with the mission 'The prodigal prince' when I have to practice with the hidden blade. Sigurd just stands there and doesn't move or talk.

    I cannot believe you guys still haven't come with a patch to fix this issue when apparently tons of people have this issue.

    Do you even care? I bet not cause you already took my money.

    The same goes for Watch Dogs Legion. There's a huge bug which doesn't allow you to save your progress.

    I pre-ordered Immortals Fenyx Rising but I canceled it. No more Ubisoft games for me.

  • SpellsRain
    1 posts

    Same issue as the others, im stuck in this stupid quest. Come on Ubisoft do something it cant be that difficult. I bought the game a Week ago and still cant play it. May be a nice step if you give us something to make up for the mess you programmed. I never liked Ubisoft cause u destroyed Division so hard but with Odyssey you get me i thought that the AC series is a good one, but after this huge failure with AC Valhalla its just ridiculous to buy another game made by u. You really should be ashamed about it @Ubi-Swaggins

  • JJWW33
    4 posts

    @ubi-swaggins He isn’t a beta tester. Don’t you pay people to do this for you? It’s such a common problem you had to be aware of it before launch, but you launched anyway.

  • JJWW33
    4 posts

    @cmcreed_43 or, you call your credit card company and get your money back.

  • JJWW33
    4 posts

    @ubi-swaggins How about not releasing the game until it works?

  • Zombieboy316
    2 posts

    AC Valhalla glitched early Monday on the elk-comb quest. I found the comb for the woman.., but couldn't speak to her, or anyone else at Fornburg (despite them having speech bubbles). Reloaded the game, and fixed the speaking.
    Played for a couple more hours.., and then it glitched AGAIN !!
    Now I am stuck, and cant do anything. This time uts in Fornburg, I met w/ the king and then Sigrid. They gave me the hidden blade. And Sigrid told me to walk w/ him down to the docks. But when we get there.., he just stands there..., cant speak to anyone, cant walk beyond general area, cant fast travel, etc.
       I have reloaded the game 5-6 times..., incl from a previous autosave from the time Segrid first arrived. We go through the dialogue again, get the hidden blade..., and then walk to the dock. But same thing !!!
    I have no older previous saves from before meeting Sigrid.
    PLEASE HELP !!!!

  • AdeiGamer
    1 posts

    Same problem here, I spend 8 hours doing all the secrest ande im stack in 'The prodigal prince' quest, I love the 8 hours that I played but this just broke me, I hope that you fix this as fast as you can

  • Joshem1gib
    4 posts

    Mine has been like this for 2 days now, there's isn't any answers from developers, complete joke waste of 70 quid

  • sykness363
    1 posts

    the prodigal Prince is like the 3rd mission (where you get hidden blade). Iv tried it countless of times, going back to previous saves, starting mission again, quiting game, restating console, literally tried everything to get past this mission but when I’m tasked with following sigard to the docks nothing happens, he just stands there, read a few other posts and I believe I need to get a cutscene, but nothing happens. PLEASE SOMEONE HELP

  • guest-m99JJraJ
    1 posts

    I keep running into an issue where the "talk" option refuses to work and i think that's a part of what's stopping the quests, but it isn't just the quests, it's everyone. Was able to fix a little of this by loading old saves but now it's just fully stuck with sigurd on the docks. It looks like the game doesn't register that he moved properly, if i yes the odins sight on where he was standing near the dummies for the stealth kill tutorial where he was glows blue even though he's standing at the docks.

Suggested Topics