ubisoft forums

Quick Suggestions

  • Rok_clima
    1 posts

    I've have the same issue with "the prodigal prince", I've also had to restart my game due to the "Seer's Solace" quest and have also had to go back to earlier save files due to a bug in the world event that involves fighting 3 people on the docks. This game is so frustratingly buggy, I was so hyped for this to come out and can't believe how much of a let down it is.

  • SerialGamist
    1 posts

    Hello Ubi, do something, 48 hours now. Give a [censored] maybe?

  • Devaustus
    5 posts

    Finally gave in and restarted, did the main story only in the first area until I made it to england what a damn shame.

  • Oth4x
    3 posts

    Seriously, we paid the full prize of this game when it clearly isn't finished and not ready to be launched rofl [censored] is this, already 2 days passed and still can't play the game I paid for since day 1 due to several gamebreaking bugs, just lmfao

  • Shrekstafa777
    6 posts

    @creed-maste1994 ya me too. Just got through the quest. Sucks I had to start over. I think it was the mysteries questioned that glitched out. Did you have a problem with those as well?

  • zeldafan4life
    4 posts

    I did a manual save after doing the practice with the assassin's blade and it worked! Sigurd talked to me and I was able to move on. Xbox one.

  • Obscurayos
    2 posts

    After completing the blade training *assassination of dummies* the task to follow sigurd is permanent. You cannot interact with him whatsoever. I have tryed to reload from further back in the story on 5 different point atleast 15x. Tryed to change behaviors. Talking to more or less npcs. Blocking others in their pathing. Tryed suicide. Everything. The game is glitchy overall but it was bearable till this. I am litterally stuck unable to play *at all* since this mission restrict movements. Fast travels or any activity whatsoever. I really regret my preorder right about now. This is not a glitch that can be acceptable. Its litterally the one thing *main story* that cannot be glitchy or bugged. I really hope you can fix this soon...

  • PrefacedPiano90
    1 posts

    Hello, i have done 6 hours worth of side activities up to the prodigal prince quest and i am having this issue. I have completed all raids and many stranger missions. Only 4 wealth objectives left too! @ubi-swaggins

  • sofakinghot369
    2 posts

    Extremely annoying tried everything cant get past this point. Have had other issues talking to NPCs but have reloaded and been fine. Super aggravating cause game seems to be badass and I would really enjoy getting to actually play the damn thing

    1 posts

    I spent like 7-8 hours trying to play and figure out other bugs for the game. I go through this mission and get stuck at the docks watching the mission symbol above sigurd disappear and the auto save symbol pop up. But nothing. No talking, no progression. Its infuriating. I dont want to restart, thats not a "work around"

  • sofakinghot369
    2 posts

    Annoying as [censored] cant get past. Tried everything. Reloads shoving him catching myself on fire literally everything. Very upsetting...

  • wiseman2908
    4 posts

    Still bugged. Any sign of a fix on the horizon???

  • wiseman2908
    4 posts

    I’ve tried deleting saves, reloading before mission, basically everything other than restart the game after 8hrs of play time...(ps4)

  • wiseman2908
    4 posts

    @ubi-swaggins any fix on the horizon??? Other than ‘restart the game’ which is not a fix

  • Royaljatt
    1 posts

    Unfortunately, delete the saved data and start from the very beginning of the game (not only the quest) in order to progress. Had the same issue and the method worked well, a couple extra hours, but its worth it.

  • guest-yvTFVrSF
    13 posts

    @wiseman2908 Same. Nothing. Absolutely not starting over.

  • Ubi-Swaggins
    Community Manager 439 posts

    Hey folks,

    The team are still investigating this issue, in the meantime we are aware that players have found success with restarting the game from the beginning.

    Obviously this isn't an ideal workaround and for that I am sorry.

    Should we receive any further information regarding a fix or alternate workaround, we will share it with you.

    Official Response
  • Orzhovian10
    2 posts

    This is beyond frustrating. Are you saying just re-start or delete all saves and start again? When replaying what should I do to avoid a repeat of the same thing? Am I supposed to do no exploration and side quests and just follow the basic story line until I’m past this section of the story-line?Some clarity would be appreciated-I will restart this but I won’t be doing this a third time!


  • Orzhovian10
    2 posts


    re-starting after 8 hours of play isn’t a “workaround”!

  • ryanmaca94
    11 posts

    Any update on a fix?

Suggested Topics