ubisoft forums

Quick Suggestions

  • R4MPZY
    13 posts

    @ubi-woofer You said the option to continue reopens at a later time, is that also true when you could not even select the "now is not the time" option? My quest disappeared before i could even start it. It is beyond my understanding that there would only be 2 "real" romance options, and 1 of them being bugged since release without any fix. How was this never noticed during bug testing ?

    If only Soma was romanceable sigh

  • Mirula
    3 posts

    @ubi-woofer So we don't have to "strengthen" the current issues going on in the settlement to show that we experience similar issues? On Xbox One X I have the same problem with Randvi and Tova (quest disappearing after completing and them not being interactable/romancable), but when I try to support a case on it the website doesn't let me choose an option to submit a bug.

    What is your advice on how to deal with it right now? Just continue on after choosing "now is not the right time", or reloading a save and wait with doing the quest?

    I've completed that quest today so for me it would only be 1 hour of progress being lost. I really hope they come with a fix for these bugs soon, because they prevent character customisation AND major romances in the game..

  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Hey all!

    @Zer0524 - We appreciate your ongoing patience as the development teams looks at this further, and we hope to have news of an update to share with you all soon! I'm afraid at this moment we are unable to provide a definite ETA for this, so please keep an eye out within the forums. Additionally, you may want to check out this thread for more information regarding the issue with Tove.

    @hayd014 - I'm sorry to hear this. Please be assured that the team is investigating this issue further. Once we have any news to share regarding the investigation, it will be posted within this thread, so please do keep an eye out for this. Thank you!

    @R4MPZY - I'm afraid I'm not entirely sure. As Ubi-Woofer mentioned earlier in the thread, they encountered this issue themselves in-game and were later given the option to romance Randvi again following the selection of "now is not the time," so it's possible the option may reopen to you as well, even if you were unable to make a choice yourself. I do agree, though - I would definitely like a couple more romance options (Soma and Birna would be at the top of my list for sure)!

    If any of you play on PC/PS4, please consider opening a support ticket and submitting your save files for further investigation as well! This would be very helpful in taking a closer look at the issue. Thank you!

    Official Response
  • R4MPZY
    13 posts

    @ubi-borealis It is actually a sign of relief that some ubisoft employees also like other characters as possible romance options ( Soma & Birna ) even if it may never happen.

    And yes it has been said that the option to romance Randvi reopens later in the game if you made the "now is not the time" choice, but what is bugging me is that i was never able to even make that choice ( or even start the Randvi quests ).

    So i'm a little concerned i would finish AC:V, doing everything there is to do, and end up being unable to romance Randvi ( i know Petra is another romance option but i want my Eivor to romance another Viking, sorry Petra 😛 )

  • Font81
    19 posts

    Just finished the game and got the platinum trophy.

    Can confirm that speaking with randvi at Gunnars wedding opens the romance option. I had chosen the "now it´s not the right time" - taken for granted quest.

  • Zer0524
    10 posts

    @ubi-borealis @ubi-woofer hello there, it's been MONTHS and the issue is still present. "taken for granted" is still not in my finished quests log and i cannot romance randvi after i chose the option "right now is not the right time" she acts as if nothing ever happened, i can only talk about the alliance map with her. any updates on when this is going to be fixed? waiting for such important fix so long is quite disappointing. and yes i know the option will come up later but that's towards the end of the game and i would like to romance her now.

  • Zer0524
    10 posts
    This post is deleted!
  • SFHSSpartan
    1 posts

    I finished the "Taken for Granted" quest with Randvi in Grantebridgescire and told her "Now is not the right time." I returned to my settlement and saw the option to talk to her about us, but did not click it and instead continued with a new alliance. After I returned to Randvi to report on my new alliance, the other dialogue option to continue the romance was gone. Is there any estimated time frame in which this will be fixed??

  • LedoveeeKladivo
    64 posts

    continue with the story till the end 😉

  • Ubi-Viral
    2366 posts


    We've received reports of players unable to continue the romance with Randvi after choosing "Now is not the right time".

    The development team has been made aware of this issue and they are currently investigating it. Once additional information becomes available it will be posted on the forums.

    Apologies for any inconvenience that this issue has caused.

    Thank you.

  • guest-lZvcZ9Km
    1 posts

    I have the same issues mentioned, playing on Xbox one - Selected "Now is not the right time". Quest disappears. Randvi dialogue disappears.

    This was in addition to 2 more issues that occurred at the same time (returning from east anglia). I have an '!' mark on the quests menu tab now that won't disappear after returning from "Taken for granted" and speaking with Randvi. Also, the Tove quest 'Carrying the torch' is not on completed, however interaction options still work.

    I've been holding off proceeding with the game as I'm aware the Randvi narrative is important to the ending? (without wanting to read too many spoilers) And I don't want to have ultimately wasted hours for this problem to affect things later down the line that I can't undo.

    However if this problem is 'bypassable' and shouldn't affect the main story or limit my gameplay experience too much, could someone let me know? I'd really appreciate that! Because I can deal with missing a few little cutscenes or dialogue bits, as long as it doesn't mess the game up! But hopefully this issue can get sorted ASAP anyway.


  • Kennyannydenny
    172 posts

    This happens also on Xbox One. The quest disappears from the quest log upon quitting the game and loading your save and the conversation options with Randvi are also gone.

    There's also a pathing issue with Randvi during this quest. When she jumps into the water she swims to the base of the tower but never actually climbs up, just laying there in the water. I can't make a video or screenshot as I reloaded an earlier save, replayed that part and she climbed up that time (so i'm way past that point). But there are several bugs (at the very least these three I encountered) related to this quest.

  • UbiExcellent
    756 posts

    @kennyannydenny Thank you for updating this thread to let us know what platform you're experiencing this issue on. I'm glad to hear the issue with Randvi not climbing the tower seems to have resolved itself after reloading a previous save. Do you recall what other issues you encountered during this one quest?

  • Kennyannydenny
    172 posts

    @ubiexcellent I didn't encounter anything else.

    It was just:
    1) the quest disappearing from the completed quests log (upon saving, quitting and reloading the save)
    2) conversation options with Randvi disappearing after choosing "Now is not the right time." (upon saving, quitting and reloading the save) Even though they should be available.
    3) Randvi jumping in the water from the bridge, swimming towards the tower and then just floating there at the bottom, not climbing up (I tried pushing her, shooting arrows in her head, etc but she didn't flinch). Reloading an older save fortunately fixed this.

  • Zer0524
    10 posts

    @ubi-viral please try to fix it as soon as possible, it's been months now:(

  • Trelleon
    2 posts
    This post is deleted!
  • Trelleon
    2 posts

    @ubiexcellent @Ubi-Woofer this issue is known and reproduced by devs since around release date. Here we are nearly 3 months later and it's still not fixed. Why is this taking so long? Is it even fixable? Did the saved data file drop the quest choices from data or something?

  • Doner07
    31 posts

    Same thing happend to me... Anyone know if it have any impact on game? i mean, do i miss some quest later in the story or maybe more important dialogs etc? (besides those romance options ofc)

  • shyam3010
    84 posts

    @doner07 nah. don’t wait up for these lot to fix it because it’ll likely be another month at least. Just carry on with your game

  • Doner07
    31 posts

    @shyam3010 yeaaah, i probably do that. Thanks for letting me know that i wont be missing anything important

Suggested Topics