ubisoft forums

Quick Suggestions

  • Smitjas2
    2 posts

    I had the issue on my Xbox one. I had just finished the East Anglia Arc, and then picked up the Taken for Granted mission and selected the Now is not the right time dialogue option. I went and did the last bit of the Asgard Arc by going into the Bifrost to end it. When I went back to the map to select the next region to commit to, the Let's talk about us option was gone. Reloaded a previous save before I did the Taken for Granted mission, and then saved it there because I don't want to go through it until the issue is fixed, rather than lose it again.

  • H0lmarn
    7 posts

    @vanillaells feels like they wont priority this problem at first hand. or second for that. and we have heard nothing about any patch for fixes

  • UnhorsedHawk89
    1 posts

    Ran into it last night after my game crashed while assassinating The Leech

  • JKristoff
    1 posts

    Playing on PC.
    I unlocked "Taken for Granted" after finishing the East Anglia arc.
    Having read around that you could romance her spoiler, and not wanting to make her a cheater, I choose the "Now is not the time" option. Now I've returned to Raventhorpe after finishing the quest in Norway spoiler, so I thought I could pick up the romance again.
    The option to do so is not there at all and the only thing I can do is either asking to see the Alliance map or leaving.

  • Jamesswan2020
    1 posts

    Yep just happened to me too, just loaded back my save and now its gone

  • SuperCharged-
    3 posts

    This happened to me aswell on PC. Now im afraid that im not going to be able to romance with Randvi so i decided to take things slow until they fixed it.

  • RobbieC988
    4 posts

    This happened to me last night. I had just finished the final quest of the East Anglia arc. I went back to Randvi, did the taken for granted quest, chose the “now is not the right time” option, went back to the settlement and wanted to see the dialogue options so I saved and reloaded and the option to talk about us had disappeared, this is incredibly frustrating. Now I have to either go back to an old save and wait for a fix (which I will most likely do) or carry on the game without the option to romance Randvi.

  • Amaya-fj
    4 posts

    Same bug but with the friendship option... It would be nice if they can tell us that we can continue with the story or we must stop because the bug will no fix your save if you end "taken for granted".
    I would also like to know if choosing "I care for you as a friend" makes it impossible to romance her later

  • viator3
    1 posts

    Just encountered the same bug (on PC). Loading a save post "Now is not the right time." option but before speaking to Randvi not only loses the "Let's talk about us." option, but also skips the discussion you are supposed to have with her after getting back from "Taken for Granted". As others have said, it also removes the quest from the completed log.

    Personally, I am hesitant to continue to play. I do have a save partway through the questline, but seeing as how this bug seems to be working retroactively in saves I don't have much confidence that even loading that far back would matter. Given how integral your decision in this instance is, and without knowing how the game is registering your choices, or if it is, it seems unwise to keep playing until the bug is fixed.

  • TwanzoTheGreat
    4 posts

    Im having the same issue on Xbox one.

    I hope this can be addressed soon!

  • TwanzoTheGreat
    4 posts

    GOOD News!
    I have been having the same issue but if you play through until the end and play the quest “Forge and Fire” it reopened romantic dialog with Randvi!

    Bad News
    It seems you can’t spend time with her and do challenges like with Petra

  • tjorren90
    1 posts

    Having the same problem (on PS4). Completed the “taken for granted” quest with the “now is not the right time” option, had the romance dialogue choice come up once and then disappear. The quest is missing from the completed quest menu. Can’t interact with barracks or shipyard and now I can’t even go to Vinland?!? Marked the quest in the log and had the quest icon highlighted above Randvi but the alliance map dialogue option is the only one that shows up. Probably 40+ hours in... Guess I’ll just hope for a magic patch soon and hold off on playing until then 😕

  • Linerak
    4 posts

    @ubi-woofer Hey, I had the same problem with Unwelcome, not a lot of people had my bug though. Again the main quest just disappeard I made my topic https://discussions.ubisoft.com/topic/79304/bug-report-main-quest-disappeared?lang=en-US And a support ticket with evidence.

  • Frogbrother
    1 posts

    Has anyone tried to hold off on doing Taken for Granted and wait with even initializing the mission before you come back from Norway? So go with Randvi on the trip after you get back instead?

  • Weltenbruch2020
    16 posts

    @frogbrother yeah...I tried that. After saving and reloading the game once the option to start the quest dissappeared as well for me....

  • philibird
    2 posts

    I am also experiencing this issue. Been a few days and still stuck.. out of ideas.

  • Tharxs
    5 posts

    I had this exact issue, asking Randvi if she's alright would cut the dialog in the middle. I read somewhere that changing Eivor's gender and then reloading the game can fix some bugs. So I tried that and I was able to finish that dialog.

  • codman986
    1 posts

    @predatorbowstan same issue with me hope they fix this bug

  • RobbieC988
    4 posts

    Can we have an update on when this will be resolved? Haven’t played the game in 3 days because of this issue.

  • DevilzCrest216
    2 posts

    The taken for granted questline has dissappeared from my completed quests and the option to romance randvi dissappeared it was thier when i went to Lundun return and the option to romance her is gone check my Completed quests and Taken for granted is no where to be found iv lost hrs of gameplay fixing bugs in this which is sad cuase i love the game but can't get over how glitched it is

Suggested Topics