ubisoft forums

Quick Suggestions

  • ElderToastMakr
    1 posts

    During The Big Finish quest when I go to grab the paint, the quest does not progress. I have killed on the enemies in the room and have picked up the crate, but the quest will not progress.

    I have returned to England and then gone back into Asgard.
    Restarted the game and console.
    Reloaded the Save.

    None of these have fixed the issue.

  • Crash14soccer
    1 posts

    cannot continue game during “The Big Finish” quest, had just had a cutscene and the rune door is open but it says i still have to find the paint

  • VictrixHomnium
    2 posts

    During 'The Big Finish' quest you head with Loki to the cave under the island. After entering the cave and killing the frost giants Loki freezes in position and I'm unable to progress the quest any further. If I take the bikes of paint back to the tower the just respawn in the cave.

  • lol2615
    1 posts

    Hello so dont know why i have few issues with this boss fight for some reason when i try to grab light to get power either i get damaged by collecting or not i am completely fine no health lose what so ever seem bit odd to me is not like i get hit by his hammer or anything cause i manage to avoid his hammer when i do that or when die and want to load my last check point and i respawn right in front of him then he tries to smack hammer on floor and agin for some reason he takes my health already on beginning or i manage to do dodge it by pressing square and same when it comes to him trying to make that move when blue wave make me jump in air so that quit annoying what ever i use in this fight there is always damage and is quite crazy damage is not like i can use them chances to often cause he take my entire health just about what is just madness and i suppose to use that to hit his spot on top of his head even if wanna use that for some funny reason when i try to shot his head arrows seems to drop fo fast no matter where or how high my aim is above his head or at his top of head all arrows drop bellow his chin so basically i spend all day on defeating that boss and i didn’t found any fight that challenging like any others basically i am stuck sorry for my english and i hope someone could help me with that 🙂

  • PortSideMike
    4 posts

    So I am trying to complete the big finish by gathering the paint that is within the cave to the south. I enter the cave, kill the mobs, grabbed the chest and finished the altar to Ymir thinking that I might not get back to Asgard after the quest was done. It is called the big finish after all. When I return to the island to complete the quest it no longer recognizes the fact that I pick up the paint and will not progress forward. So here is the dilemma, I do not have a save prior to this chain of events except for one that was forced when the builder first erected his tiny statue. Is there any way to get this quest to complete or do I need to just stay out of asgard and continue in the mortal realm as I do not want to start the whole 30 Ymir tear collection over.

  • PortSideMike
    4 posts

    @vesgo_torto Yeah I just posted this same thing and didn't notice this was already posted. Mine occurred because I left the island and came back, or because I was in the cave prior to the quest step that brought me here. I noticed that when I started to run to the cave the audio did not sink with what was happening. As in, I was getting the audio ques for what should have been happening when I was at the cave and not while I was running to it.

  • Proera47303
    4 posts

    At the point once Loki leads me to where the builder hides his blue paint, Once I defeat the enemies and try to carry out the paint I get no dialogue or an option where to set the paint at or anything.

    1 posts

    I'm at the end of the big finish and I pick up the paint and it still says find the paint. I take it to the tower, and nothing. I've left asgard and returned, still buged. Loaded previous saves, still bugged. I'm 30 hours in the game so I'm not restarting the game. Fix this. Ever since you guys released breakpoint brocken ubisoft has just rushed and released brocken games. Your driving away long time ubisoft fans.

  • Goughman01
    1 posts

    Hi the quest "the big finish has bugged out and won't let me carry on progressing with the asgard story arc, the quest breaks when you have to search for the builders paint.

  • frost686f
    1 posts

    I'm having the same issue on PS5.

  • Ubi-Swaggins
    Community Manager 439 posts

    Hey folks,

    If you are encountering this issue, please upload your save data to us via our website, so it can be passed onto the team.

    Thank you for your patience and understanding.

    Official Response
  • FriedrikLucas
    1 posts


    My game is softlocked after a buggy boss fight in Asgard during the quest "The big finish". After a fight where the Builder did not trigger its mid-life dialog, I killed him but nothing happened after the killing blow. I was stuck inside the arena so I fast travelled to the central tower. However, the game still wants me to kill the Builder (which I can see dead in the arena). I can't travel out of Asgard so I'm essentially stuck.

  • SaintsFaII
    4 posts

    @portsidemike same bug

  • Alteran6
    5 posts

    After returning to Asgard the whole quest does not trigger. It is stucked at point where im prompted to drink the potion to return to asgard but when i drink it and retzrn to asgard quest swill show drink the potion.,

  • chrins
    1 posts
    Hey there, thanks for getting in touch! What happens when you pick the paint up and bring it to the tower? Does the quest continue or does nothing happen? Would you be able to provide a video of this?

    same problem, when pick the paint doesn’t happend anithing

  • KarmaDash
    7 posts

    @ubi-swaggins I don’t have the means to upload my save data from my PS4. Is there any other way to get it, or have you gotten enough to find the bug’s origin?

  • FIaminase
    1 posts

    Same issue on pc..
    stuck with the objective to investigate south to the tower. At the door Loki triggered the cutscene but after cleaning the room from enemies the three builders paint wont get recognized even if picked up. I've tried multiple reloads, wake up from asgard and come back, exit the game but nothing works. Now also Loki disappeared..please fix this

  • kbtaylor18
    4 posts


    I am currently in Asgard as well. I have “defeated” the builder but I can’t do anything else. Once I defeated him, there was no cut scene and I could t leave the tower. I was able to fast travel out of the tower, but not out of Asgard and the quest log still thinks I am in the “defeat the builder” stage of the quest so I can’t leave Asgard, I can’t save my current game. I tried killing my character to see if it would reload and trigger the cut scene or even just let me defeat the builder again. It won’t. So I ran around Asgard doing some other things seeing if it would trigger anything; it won’t and also won’t let me save that progress either. I can’t get back into the tower, the shield thing is still up. So I’m stuck in Asgard, mid boss fight, can’t replay it, can’t save and can’t leave. My biggest mistake being that my last manual save was like 20 hours of gameplay prior to this. I’m super frustrated. Is there a fix for this yet???

  • Wahn128
    1 posts

    I had the same issue with getting stuck, but read about a way to resolve it. Just thought I'd share that here and hopefully one or two of you might find it helpful:

    1. Reloaded to before speaking with the builder
    2. Watched the Freya switcheroo cutscene
    3. Walked beside Loki disguised as Freya and waited there for talks playing "why are you still Freya, turn back, bla bla" (at the same time, all of the other spoken messages that I guess were supposed to play in the cave also played)
    4. Once he transformed back, I walked together with Loki towards the cave (the transformed giants became quest markers at that point; strangely two of the deer somehow made it out of the cave and I had to run them down and shoot them)
    5. Reached the door in the cave, kicked it in with Loki, killed the giants and the paint boxes became quest markers
    6. Brought one box back, with Loki chatting my ear off on the way there, and putting it down started the boss fight.
    7. Killed the boss and made it out of Asgard

  • Itzxnate
    2 posts

    When doing the quest when the builder brings the shield up, I woke from the quest to return to the normal game to upgrade my gear. Upon my return to Asgard, there is a bug that makes it where you are killed over and over by a green light no matter what you do, making the quest impossible to complete and making it impossible to progress further in the game. There is a Reddit form where people have claimed to have the same issue so I know it is not just me. This bug needs to be patched ASAP as it prevents further completion of the base game since you cannot level up Eivor without the quest line once you get to a certain point in the game.

Suggested Topics