ubisoft forums

Quick Suggestions

  • Alpha-Woodzs
    11 posts

    Same issue really bad nearly happened to me at the start of the game doing a mission but managed to fix it this is a joke.Tried everything really need a fix for this may I remind ubisoft it was a €109 to buy this game I'm barley started the game.ive seen bad games this year but at least you can finish it. Your seliing faulty products and I call it day light robbery and at this stage accountability needs to be had I'm fuming and can't even look at the game it I'm so annoyed.

  • A Former User
    0 posts

    Just like everyone else im hoping ubi sort out a fix for loki on the big finish in asgard on all platforms.

  • cason.davenport
    2 posts

    I’ve now updated and it’s still doing the same thing. I’ve waited patiently for the update in hopes that this would be fixed. It’s extremely aggravating to not be able to finish the game because the developers didn’t test the game before releasing it.

  • Edge_of_Cosmos
    2 posts

    I just installed the latest update and I still can't complete "The Big Finish" quest. The game doesn't react to me picking up the paint, Loki is still in Freya form, nowhere near the "paint" room. I can't go back to older save cos I don't have any. This sucks.

  • dennik02
    4 posts

    Ubisoft are you SERIOUS? For what i downloaded the update, when its still impossible to complete this "big finish quest". 5GB download for nothing, if its not fixed till one week im going to delete this game.
    Only frustrated because if you

  • Yergert690
    1 posts

    Still broken. Nothing seems to have been patched regarding this quest. This is so disappointing and makes me lose tons of faith in Ubi

  • powerskym
    1 posts

    undefinedloki was dead. quest line stop.

  • knight_2008
    1 posts

    "Builders paint" part still not progressing even after this update.

  • BigSauceee
    1 posts

    Waited 2 weeks for an update...Woke up happy thinking it's going to be fixed... Nope. But don't worry, there's a new pack you can purchase and wear for this broken quest!

  • ozisim
    2 posts

    I just installed the 1.04 update on PS4.
    still can’t get past this Search for Paint point.

  • Proera47303
    4 posts

    @ubi-woofer nothing was ever fixed, thanks for not telling them anything 🙂

  • F7RON
    2 posts

    Guys just relax, go play the rest of the game, watch the cutscene and stuff on YouTube and come back to the game in a couple of weeks when this is resolved. Everyone complaining that they can't do 30 min of gameplay and their money is wasted because of it really needs to calm down. You've got a 100+ hour game you can get back to instead of crying because of a sidequest.

  • Nic0hddv
    2 posts


    They probably did test it , just said f it and released it anyway . Glad i did not spend anymore than the extremely overpriced amount for a game that has more bugs than an anthill not to mention i bought the digital key so i'm stuck with it now alltough probably won't play it ever again. Shame too , could have been the best ac so far.

    There is a lesson to be learned here tough , don't buy an AC game on release , wait , buy it cheaper and have an overall better experience for less money . I'm deleting the game after i post this , still had 1 more region to do but honestly i'm just fed up . Realy hope they get a lawsuit with a hefty payout , this is basicaly theft .

  • optimisticflat
    1 posts

    undefinedLoki wouldnt leave the tower so i shot him with arrows to push him to the cave. This got him halfway there when he eventually died. So now ive killed a god and have no way to progress in the quest. There really should be a restart quest option. I'm 70hrs in and starting over is out of the question.

  • prudcop
    4 posts

    @f7ron well thats exactly what i did
    now im around 150hrs
    everything is done, only part Left... asgard
    so yeah i think i have the right to be upset after buying the collector édition for 300$
    We, players, are in our right to have a complete unbroken game the day it release

  • sparkywilly
    1 posts

    Unable to progress past “Loki notes activity south of tower” Loki was hanging out just outside the tower but I lured the enemies from inside the cave outside and they killed Loki. I carried his/her (he is still appearing as freia) body into the cave hoping it might reset something but it didn’t. I left Asgard and did other quests and returned hoping something would reset but still nothing has and now Loki’s corpse is still just lying in the cave where the paint is.

  • linerhead
    3 posts

    So they didn't fix this quest? OMG

  • Alakfron
    2 posts

    The update didn't touch on this quest at all..... Good to know slight problems take priority over game breaking bugs. How did a glitch this critical even make it past bug testing! Disgraceful Ubisoft. PEOPLE CAN'T BEAT YOUR GAME!

  • Alpha-Woodzs
    11 posts

    1.Still can't do mild hunt
    2.Still can't do ledecestrescire hoard map
    3.Still can't finish asgard due to lokie issues.
    4.can now see all skills that I haven't got too yet don't even know if that was intentional.
    5.Still no response from ubisoft to say we ducked up again.
    I really don't think there is a point in playing as what else is going to go wrong there has to be a refund process for
    this or compinsation absolute madness

Suggested Topics