ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] Unable to progress with "A Wise Friend" as Randvi does not meet with Valka | POST HERE

    14 Likes/392 Replies/51495 Views
    9 posts

    @backhand187 alright that’s good to hear!!

  • King199616
    2 posts

    I did the map quest but I still don’t have the quest a wise friend. My settlement is level 5 and I’m super frustrated, nothing is working and I don’t want to start over

    @lucien_aus what do you mean nearby? My settlement is level 5 and I built her hut and I still don’t have her quest

  • King199616
    2 posts
    This post is deleted!
  • Alexczy
    2 posts

    Me again, I contacted support.
    They suggested me to Validate Game Integrity.
    I did an it is fixed now!!!

    I can continue the story. Finally, it was about time.

  • achu_Poland
    1 posts

    I Have the same problem on PS4. When I meet Valka at the docks, she asks me to help carry her luggage. So I take the crate and follow it. After talking with the blacksmith, he goes nearly to the long banquet house, stops and I can't do anything else. From this moment on I can't take any new missions or talk to anyone .... all I can do is upload the save before I took up the mission "A Wise Friend". I've already lost 50 hours ...

  • FenSiriunIxx
    1 posts

    I had to reload a save prior to engaging either quest. Complete Settling Down and The Alliance Map in their entirety before starting A Wise Friend by talking to Valka at the docks. With no mission dialogs holding Randvi in place at the map, she was exactly where she needed to be to engage with Valka and continue A Wise Friend.

    Additionally: as Valka arrives once Ravensthorpe reaches Level 3, my loaded save was prior to making the needed upgrades. As such I made sure Settling Down and The Alliance Map were completed prior to making my last upgrade to level 3 to avoid scripting conflicts entirely.

    Between both of these I was able to completely bypass the problem.

  • Gamebytesbiz
    2 posts
    This post is deleted!
  • Gamebytesbiz
    2 posts

    Here's how I fixed it.
    Problem 1: You find Randvi in the longhouse by a map table. She should not be there yet so you cannot click her.
    Problem 2: You started A Wise Friend Quest where Valka will get stuck at top of the hill. (She is not stuck she is expecting Randvi to be there to chat to her on the way to the hut).

    1. Save the game and exit.
    2. Verify Game Files on Ubisoft Connect.
    3. Go back on game and now Randvi is standing outside (where Valka gets stuck) and again you cannot click her yet.
    4. Proceed down the hill to the docks and help Valka carry the boxes.
    5. You will now see Valka stops to chat with Randvi on the way up to the Seer hut as its supposed to be played out.
    6. You can now go back to Randvi if you wish (who is waiting back inside the longhouse) to start the Alliance quest.

  • Furiaen21
    1 posts

    PC Player
    Verified Game Files
    Valka gets stuck at the fork in the road where she needs to talk to Randvi.
    I've fast traveled to Norway, come back, I see Randvi at the top of the hill where she needs to be, but when I go and grab the luggage and make it back up the hill she is always back in the longhouse unclickable.
    I did not have a previous save available. It's all or nothing.
    I decided to then try building the hut. Still same exact bug after building the Seer's Hut.

    Did some side quests around my settlement, some fast traveling, etc... ran into ANOTHER BUGGED quest "Have you seen this man" where I turn invisible during "Try it" and cannot complete/progress/become un-invisible.

    I paid over $130 on a preorder that clearly wasn't ready to go. I've got 30 hours sunk into this playthrough already and I don't want to start over. I normally end up investing 200+ hours in a single playthrough. I literally cannot progress main story without this bug getting fixed.

  • Katack2011
    2 posts


    As the title say, im currently stuck with the quest Wise Friend on PC.
    Valka is simply stuck on top of the road (on the Y path, between the tree, the longhouse, and the tattoo shop).

    I have completed the Ragnarsons and Grantrebridge quests.
    From a video i have seen, Randvi is supposed to be there and speak to Valka, but it's not the case.

    In fact i've found Randvi at the entrance of the map room, but not moving further from it.

  • theatomiccat10
    7 posts

    Playing Assassins creed Valhalla, a glitch with the quest "A Wise Freind" where Valka stops and does not move on near the longhouse. I have restarted the game and re-verified game files

  • mehrlicht
    10 posts

    I have the same issue.

    Just tried doing the following:

    1. Save & Exit game
    2. Verify local files
    3. After loading game Randvi is on the road where Valka stucks (can't interact)
    4. When I come to Valka, Randvi starts moving to the longhouse
    5. When Valka comes to the place X, Randvi is already at the longhouse...

    Don't know how to deal with it :c

  • Art.Dz
    1 posts

    same here
    why this post doesn't get any attention from Ubisoft????

  • KimJongChae
    4 posts

    @furiaen21 same thing with me, also PC. verified all my game files. did some side missions then restarted the game. Nothing. i did all the other main quest lines before her. i have no previous saves without being set back HOURS. the only thing that people say fix it overall is reinstalling which in this case like you, i do not wish to restart the WHOLE STORY MODE. This needs to be fixed

  • KimJongChae
    4 posts

    forgot to say this was a wise friend quest.

  • Tim_Roy
    1 posts

    Bonjour, j'ai un problème dans la quête ''une amie avisée''. Valka s'arrête au moment où elle doit parler à Randvi (qui n'est pas là du coup). Je suis allé voir sur des forums et je ne suis pas le seul mais les solutions trouver par d'autres (faire les quêtes du début en parlant à Sigurd et Dag aux écuries,... )ne fonctionnent pas avec moi

  • torind2000
    3 posts

    Ditto, can not complete,. tried earlier load, tried relogging, tried building the hut first. valka just stops and goes not further.

  • Brane_
    2 posts

    @furiaen21 I am in the exact same situation, literally tried every solution I found on the internet. Seems like Ubisoft has no idea this is happening.

  • LordAussie654
    3 posts

    When Valka gets to the top of the hill she doesn't move, I know she's meant to talk to Randvi and I've tried everything to get randvi out. Done nearby quests, travelled to Norway, upgraded my settlement to a new level, nothing works.

    Any tips??

  • Brane_
    2 posts

    @lordaussie654 I’m having the same problem and have tried everything, nothing fixed it for me

Suggested Topics