ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] Unable to progress with "A Wise Friend" as Randvi does not meet with Valka | POST HERE

    14 Likes/392 Replies/51306 Views
    8 posts

    @eomydior funny enough, I think me interacting with the decoration when I was supposed to be listening to Valka is actually what broke mine in the first place

  • guest-CUSMbh0p
    1 posts

    Cannot finish quest “a wise friend” in ravensthorpe and because of it all of the npc can’t talk either. From the black smith to the thousand eyes. I can’t do anything. Basically stuck in this point in the game because of this bug

  • CostlyTurtle336
    8 posts

    @c1985j OH...MY GOD. It worked. I want to cry from relief, this glitch has been so frustrating

  • CostlyTurtle336
    8 posts

    @ubi-woofer disregard, I followed another poster’s suggestion of going into completed quests and clearing them all out, then Randvi walked down the hill and Sunniva left

  • stuart_bar
    1 posts

    @Utzung thanks, this worked for me.

  • SeverHeadcase
    3 posts

    I managed to fix the issue which persisted even after building Valka's hut, by fast traveling to Norway and back again.
    This time it played through until the end.

    BTW don't do the next Valka part by drinking the potion to start "in a dream" until suggested power 90.

  • Viralflea
    1 posts

    Since competing in the yule events my player respons drunk every time , the seer stops walking half way to her house when trying to complete a wise friend and since upgrading the settlement I can't use anything in it , nor can seem to get any new quests , alot of hours have gone into the game and to say this sucks is an understatement

  • lukikuais2
    1 posts

    i use to have the same bug with her, so i change the video settings to a high resolution and the mission was completed

  • McAbree
    3 posts

    None of these methods does not work for me.

  • Milliman4
    3 posts

    Not only does Valka get stuck, but any time I reload a save I am drunk?

  • EggKnobble
    36 posts

    Had the same issue, but i cranked up all the settings to max/ultra. And there she was. After the restart of the game.

    Maybe it helps!

    3 posts

    I'm here to confirm that change graphic quality to Ultra High work for me (PC) Radvi teleport from her office to point that need to greet Valka then everything but my frame rate is smooth as fluid
    But I not sure it's bc I didn't finish built Seer's Hut before starting this quest or not (But If it is restart game should be enough) nvm I hope you all can pass this quest as well.

    And now I can upgrade my gear again. Holy Jesus

  • rboyle75
    2 posts

    @ubikobold Still doesn't work

    I did it the first time, but now no luck.

  • Promethius1949
    2 posts

    @rodich I have the same problem their looking into it hope for a fix soon.

  • calt59
    2 posts

    The work around works but what a PITA
    You would think that a know bug like that would be fixed quickly
    Not happy wasted over 4 hours before I could move on

  • PeterBolinder
    2 posts
    This post is deleted!
  • Srky091
    1 posts

    This worked for me

  • MaciejNowak2011
    1 posts

    Hi All.

    After the Yule event was over, everything started working and the quest ended without any problems.

  • Ubi-Wan
    Community Representative 636 posts

    @rodich Hey there, and thanks for reaching out with this. We're aware of this issue, with a dedicated thread here. However, for your platform (PC) a workaround some players found effective for this issue is as follows: Try changing graphics settings to high / ultra and reloading the game, then escorting Valka to Randvi during this time.

    Do let me know if you're still having trouble after this. As for Promethius1949, can you let me know what platform you play on? There's a few workarounds which can be found in the main thread for the issue, so I advise looking into it!

    Official Response
  • LoveLeeFrankE
    2 posts

    So I’ve had 2 glitches that have persisted, both before and after Yuletide.

    the 1st I noticed after building my bakery and finishing all of Tarben’s missions. I did the fishing option and each time it would glitch and just allow me on the pier, never further.

    the other one is when Valka arrived at the settlement. Before Yuletide, I had just her tent but it would constantly glitch no matter how many times I would turn off and reload. After a point I stopped and continued w/ other things & adding more to my settlement. I made Valka’s house then tried again. The same glitch in the same spot. I basically start off fine. Meet her at the pier, talk then carry her stuff, talk to Gunnar for a sec then continue up the hill. But she stops and doesn’t move, right near the longhouse, between the tattoo & animal trophy houses. I have ran my crate to her house but she doesn’t move, sometimes when I come back to her, her crate had disappeared

    please please please help me!!!!

Suggested Topics