ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] Unable to progress with "A Wise Friend" as Randvi does not meet with Valka | POST HERE

    14 Likes/392 Replies/51529 Views
    311 posts


    Thank you! This is the only thing that worked for me, and I tried all the other "fixes". Only after going to Norway, saving, quitting and restarting, then going back to England, did Randvi ever move from her stupid table. Just going to Norway wasn't enough.

  • Wet_Baby
    2 posts

    @furiaen21 hmm, yeah so I am pretty sad right now because when I did this 5 mins ago i lost all my files. All are corrupt... It of course is not your fault, but be cautious. There is a risk. Lost about 65 hours of progression...

  • CocoricoPaul
    1 posts

    @wet_baby if you lost it through epic, try downloading uplay and verified through there, it didn't fix the bug but at least if got my save back (even if it's not epic try it)

  • Zillex234
    1 posts

    So I'm having this problem in the quest where Valka joins the rest of the Raven Clan in England. We start slowly walking to her designated hut before she just stops entirely in front of the longhouse. I've done a bit of research and I've learned that Randvi is supposed to be there to talk with Valka, but that isn't happening. I've tried everything I can think of to fix the quest but nothing has worked so far and I'd rather not install the game. Ubisoft please fix your game!!!

  • IndyApacHe
    6 posts

    @apgod48 not happening to me.

  • Miguelperre
    1 posts

    I can’t play the game I’m stuck at a wise friend me settlement lvl 4now and me lvl 72

  • Zdenislav3
    1 posts

    Hi, Ubi,

    Could you fix a problem with this quest? Valka stopped near long house and she is waiting for Randvi. I can not do anything else, i can not speak to a lot of people in the game.


  • de.rik
    3 posts

    changing the graphics to high quality helped me

  • stephsparklesxx
    2 posts

    @sainiv757 I find it quite disturbing that this has been reported since launch and still exists

    I've got it on my save, I've done the requisite quest and have done both early game story arcs, very frustrating

  • stephsparklesxx
    2 posts

    the fact that this still occurs after 6/7 weeks is pretty sad, can't progress any further until this gets fixed

    the pre requisite mission is done and both early story arcs I've verified the game files

    hope this gets fixed soon

  • dracosoul
    1 posts

    SOLUTION for A Wise Friend for me, as you walk up the path and if she gets stuck, put down the box you're carrying, instantly fast travel to Norway and then back to England. The mission reset for me on my return to England and Randvi was waiting at the top of the hill which I checked instantly on my return with raven vision. All good after that. I'm playing on Xbox.

  • SeverHeadcase
    3 posts

    I have the same issue so I went back to a previous save and ignored the quest, but now whenever I reload the game it defaults to a wise friend and Eivor staggers and the screen goes all blurry like when he's drunk until I change the quest to something else.
    It's getting to be a real pain in the behind

  • nessun095
    1 posts

    Hi, during the quest “a wise friend” happens that Valka stucks in the middle of the route to her new home... how can I fix it? I can't load less recent saves because I'm level 70 now and I've first encountered this bug when I was around level 30, so I don't want to lose my game progressions BUT I want to progress more through the quests and I can't do it without applying a fix to this bug.
    Please help me  

    Following the video reporting this specific bug

  • billerisback
    1 posts

    Same here i can't progress it any solutions ??

  • Madgamer2020
    1 posts

    Known bug, in Wise Friend. Issue been known since launch and no fix. I paid, for the ultimate with season pass. They sold this knowing the bug will prevent players, from ever playing DLC. This is a game breaking bug. Can't do contracts all NPCs in limbo. Can't upgrade equipment, at blacksmith. Cant sell items at store. Can't progress any further. This is a known issue for over a month and they are still selling useless season passes for DLC that can never be played. Game is over less than one fourth the way through, but sold as a complete game.

  • GreenTitan02
    2 posts

    Now that the mission: "A wise friend" has arrived, I cannot complete it.
    Randvi isn't where she is supposed to, and it freezes Valka in place.
    Here comes the frustrating part: I cannot interact with anyone in Ravensthorpe. I cannot upgrade my gear, I cant check the opal trades, I can't interact with the trader! you name it and I cant interact! I cannot start other missions that start there.

    I have been told if I reinstall the game, I'll lose all of my progress and I don't want that to happen.

  • iomp
    1 posts

    @taliesinward ridiculous bug though....

  • blackjack754
    1 posts

    @mcud Worked for me also, and made all the NPCs in the settlement talkable again.

  • Eduardo.PF
    15 posts
    This post is deleted!
  • sweddell
    1 posts

    read seaval solutions and none have worked for me

Suggested Topics