ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] Unable to progress with "A Wise Friend" as Randvi does not meet with Valka | POST HERE

    14 Likes/392 Replies/51555 Views
    1 posts

    A wise friend is super bugged need a fix or nun I cannot continue with the story this is fing stupid

  • stallattack
    34 posts

    @bedlamboy77 samething, I finished the game before 1.0.4 patch, didn't have many game breaking problems but now after 2 patches....like man's best friend ability not unlocking, skull cloak problem, fabric not dropping...etc. and still my game progression is stuck at 93%, ubi connect download speed is averaging 150~500kbs although I have 360~400mbps connection(what a joke) .....there are just so many more previously addressed issues are still there.....😠 😰 👺 🤔

  • Nexxolae90
    2 posts

    @ubi-viral I cannot upload my savefiles to a ticket. The supportsite doesn't let me open a ticket because the live chat is down and I can't choose another method to contact support.

    Are there any ETAs for a solution already from the Dev Team?

  • KimJongChae
    4 posts

    @utzung my god this worked thank you so much, was stuck there for DAYS. Had to put down the game. Ended up finishing alien isolation bc i had no way to play AC lol

  • Sainiv757
    1 posts

    Hi I cannot approach any NPC for any dialogue in settlement neither can I complete the active mission A wise friend as the lady just stands there does not move an inch after a little walk.

  • MKL.-
    2 posts

    This helped me, many thanks.

    Sadly, another bug appeared right after finishing this cursed quest. And this one is truly game breaking as it doesnt allow me to move, and do pretty much anything else.
    After finishing the 2 main quests to pledge with the two out of three sides and finishing the Wise Friend quest, it tells me to talk to Randvi and welcome that new kings son to your clan. I proceed to talk with them and welcome him, this quest marks as finished, and right after that it says Pledge finished (or sth like that) and Randvi tells you to go with her and take a look at the map, and thats the moment where I get stuck in the dialogue/cutscene thing, cant save, cant move, cant interact, nothing happens at all, the game goes back to the "free roam" but im just standing there, stuck. When i quit to title screen and start again. Everything i mentioned happens the same way. I tried skipping the conversation, same issue...

  • torind2000
    3 posts


    This is awful. How was this bug not tested for? Literally DAYS of not being able to actually play the game I PAID for.
    I can not progress in this game which means I've wasted my time and money on this game.
    How does one go about getting a refund for this?

  • MKL.-
    2 posts

    Managed to solve this issue by reloading the game a few times, until it suddenly, without any reason started working. Weirdly enough, there is no talking to randvi and looking at map part, as it triggers a longer cutscene and forces you to do some main quest after that.

    So just a warning to those who may experience this issue.

  • Persian09
    2 posts

    I still have the problem and did multiple solutions but still didn't work. Does anyone now what I can do or should I just wait so it would be fixed?

  • SaiRoland8
    1 posts
    This post is deleted!
  • guest-zgBbpyej
    3 posts

    valka is stuck she will not move once at the fork of the hill I have seen ways to fix’s this but that insists that a loose my progress I don't want to do that because I have Excalibur I just got 10 minutes ago so please can someone help me

  • Persian09
    2 posts

    Ok people I have found a solution for my problem (hopefully for you guys aswell), I did the following thing.

    1.travel to Norway

    2. travel back to England/Ravensthorpe

    3.do NOT start the quest yet, go up to the top of the hill where valka usually stops and sigurds wife will be standing there. push her down the hill with your horse for a few meters(ill explain this in a sec)

    4.go start A Wise Friend, pick up the box and sprint to the blacksmith. sigurds wife will begin moving back toward the longhouse until you reach the blacksmith. we gave you time to get to the blacksmith by pushing her down the hill with the horse earlier.

    5. breathe a sigh of relief.

    Credit: succmaster69420 from reddit

    Hope it works for you guys aswell.

  • Wet_Baby
    2 posts

    I also have the same issue, whenever I load in the game Randvi stands where she is supposed to greet Valka when she walks by, but whenever I begin carrying Valka's stuff, Randvi disappears into the Alliance Map room. Therefore whenever I reach the place where Valka is supposed to be greeted by Randvi, Valka stops in the middle of the road and I can't access the Alliance Map. I do not know why this has happened, but I don't seem to be able to interact with any npc in my settlement either, it is very important this gets fixed soon.
    I researched this, and some people managed to fix this by simply just going on a quest, returning and everything would be fine, or maybe travelling to Norway and back, and suddenly it would work, but none of these fixes seem to work for me. I hope Ubisoft have taken notice to this issue and are fixing this right now, because this is a game breaking bug, that will cost them in players, and such. I really hope this is fixed quite soon, because I really enjoyed the game, and I do not wish to start a new save file, so I will cross my fingers.

  • nomercy375
    2 posts

  • Ubi-Viral
    2366 posts

    @ilhano1995 Hey!

    We've received reports of players unable to complete the quest "A Wise Friend".

    The development team has been made aware of this issue and they are currently investigating it. Once additional information becomes available, it will be posted to the game's official forum at:

    If you're on PS4 or PC, we would appreciate if you could also forward us your save files. You can find further details on this via the link below:

    We apologize for any inconvenience and thank you for your patience and understanding while we work to resolve this issue.

  • nomercy375
    2 posts

  • Ubi-Viral
    2366 posts

    @nomercy375 Hey! We are unable to see your reply. Can you try sending it again?

  • LordMarron
    1 posts

    @persian09 i'm playing on PC and it doesn't work 😞

  • CRIGGA330
    2 posts

    I can not progress through A wise Friend mission. No one will come talk to Valka and I have quit and tried a few different work arounds. Please Help ASAP!!!

  • IndyApacHe
    6 posts

    I already played the game twice and all went smooth. Now, in my third experience, I am having this problem. I thing it's related with the Yule Event.

Suggested Topics