ubisoft forums

Quick Suggestions

  • Ethanreves682
    2 posts

    UPDATE: completely starting the mission over seemed to resolve the issue.

  • Mechy01
    1 posts

    Going under the waterfall for one of the books of knowledge, I started to go into the cave and was greeted with the "Area Unavailable" words right in the middle of the screen. I backed up... went in and out of the game...then I just figured let me save the game and go in anyway....well, nothing stopped me. I did have to break down what looked like the end of the map but I think it was suppose to be ice....not sure....but yea...that's mine.

  • Nightally
    5 posts

    1: almost none of the world events can be completed
    2: getting attacked by a boar, while on a horse, crashed the game
    3: random pits in the ground where you can't get up if you fall down
    4: NPC interaction not working unless you blow the horn a few times
    5: getting killed by bosses makes you move slow instead of dying and every NPC stops moving
    6: dude stuck in a chair
    7: dude eating an apple or something, but his hand is empty
    8: 2 dudes fighting, but they're like 2 meters apart
    9: loading a save creates another save or overwrites or something, I'm confused
    10: can't even start some world events because the NPC can't talk
    11: treasure description tells me to go somewhere and see something far away, but the thing I'm supposed to see is too far away to render. I'm on max settings with a 3080.
    12: using the skill to switch which hands your weapons are in, while holding a torch, then throw the torch. It throws your weapon instead and you can't pick it up
    13: doing raids doesn't give you any indication of when you have completed it. Not sure if bug or crappy lack of feature
    14: horse can climb like skyrim spiderhorse
    15: sound cutting out every now and then

    I'm still in the starter area. Putting the game on hold until they fix the world events

  • Ghh272
    1 posts

    I'll be playing and eivor will move by himself and the camera angle will move own its own and then disconnects my controller. It isn't my controller ive tried 3 of them and it does the same thing and doesn't do it on different games

  • Gamgin
    1 posts

    I can not access the Ubisoft club, store, or Redas. On PS4. (0x7000015f)

  • styl_fly
    3 posts

    Playing on ps4:

    I've ran into a few strange glitches/bugs so far - the most annoying is getting caught up on a rock or something on the ground while running.

    There's 3 treasures along the river bed in grantebridgescire, I can see the gold icons on my map and with the raven - but there's nothing there. I've swam around everywhere while pinging Odin's sight but found nothing. I checked a video on youtube out of frustration - these treasures just aren't spawning for me. If it's not a bug, my only thought is maybe I'm not far enough in the story for them to appear???

    Another main issue I'm having is a wealth icon in Haervik shipyard - I've already raided the area and collected all of the wealth. But for some reason one more icon remains, I've searched the area - I can't find anything with Odin's sight or the raven. This Makes completing Rygjafylke impossible 😞

  • longjohn119
    1409 posts

    Aim assist for the bow is completely broken ..... It doesn't matter which setting you use it's all the same and seems to do nothing at all ...... Everything with a bow just plain sucks and seems like a major downgrade from the clunkiness of switching bows to not knowing how many arrows you have until you equip the bow and pull the right trigger, to the limited supply and no way to craft new arrows ...... Especially annoying because you waste so many because Aim Assist doesn't work

  • Nhyve
    1 posts

    @p2kanathip Got that duplicate too.... how can such thing happen?

  • Shylmagoghnar66
    3 posts

    @styl_fly Could it just be the chest in the "hanging" docked boat? It has a small wealth icon attached to it.
    Spend too much time to find that one, but it's not related to the 100% completion marker of Rygjafylket or trophy related...

  • brobfsu1993
    1 posts

    Anyone know how to talk to Ubba in The Sons Of Ragnar mission? I have read several other forums where people have the same issue.

  • larrykop1967
    80 posts

    So far,

    Nudist Box Bug, still not there
    Treasure Hoard not showing up in Ledecestre
    Unholy Father Crash and bug but got past it
    1 npc was missing in Lunden but appeared later after returning
    2 times Eivor did the non stop shaking, can't move, stuck issue.
    Sound levels very different, characters and effects.

  • Netspook
    352 posts

    The servers would run out of storage space if I post all bugs and glitches...

    Joke aside, can't play the game unless they fix my problem, or I start completely over.

    Multiple bugs during The Builder boss fight, resulting in barely being able to do anything at all (made a seperate thread about it). All saves except one are gone, so nothing can be done from my side.

    Right now I REALLY hate Ubi, for releasing this unfinished clusterf*.

  • sadarum
    6 posts

    the prompt to initiate the cordelia boss fight doesnt appear anyone got this problem?

  • zLophius
    1 posts

    dupe 😞 even on old saves. i tried load 2h before it happend . day. 2day ago. it doest help worst thing duplicates replace items i have . undefinedundefined

  • TH3R4BB1T
    31 posts

    I swapped places with the enemy when assassinating one, so it looked like the enemy was assassinating me instead. It looked weird and scary at the same time.

  • ExpertBanter
    1 posts

    Can’t force open doors when trying to reach geodric

  • glennapego
    1 posts

    @yerimiese_ im so glad im not the only one. i even tried reinstalling the game... but stilll, no blood fx when it comes to melee attacks. but there is blood when using assassination and arrows,

    2 posts

    Raven isn’t appearing when I press the d-pad to call in, rebooted game still isn’t working. Worked before.. can it die or something? Went to do missions in Valhalla and it hasn’t appeared since.

    2 posts

    try to use the raven vision and nothing happens d-pad works ugh do I have to start all over!?!? 😩

  • TH3R4BB1T
    31 posts

    On PC I have collected two wealth of NPC in Suxsesses (hope I write it right) and they did not trigger being collected. Could be a game time played related bug, because to longer I play the more bugs I get in game.

Suggested Topics