ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] [PC] Fire / Smoke / Dust effects causing multicoloured graphical artefacts | POST HERE

    26 Likes/263 Replies/9739 Views
    16 posts

    any news on next patch? 😕

  • Ubi-MrM
    Ubisoft Support Staff 4541 posts

    Hello everyone,

    Given the wide-reaching nature of this issue I have formalised this thread as a megathread, and have added it to our list of issues under investigation. I appreciate fully that this issue is distracting and not pleasant at all to deal with, and would like to reassure you that the developers are still looking into it. At the moment they are attempting to reproduce the effects you have provided images and videos of on various configurations, and as soon as they provide us with an update on their progress, I'll be sure to share this.

    In the meantime, as my colleague Ubi-Baron wrote previously, updating Windows to the latest version would be our recommendation as this has proven a reliable fix for several players throughout this thread already. This is a troubleshooting step we would advise for any and all of our games, as running on the latest OS ensures that you have the latest bug fixes, software updates and incremental updates that improve your system's performance.

    If any of you have any additional information to share with us, please do so. In particular MSINFO / DXDIAG reports may help, which you can submit in a support case and then quote your reference number here in the thread for us to take a look. Thank you all for your patience and understanding while our team continues to investigate this.

    Official Response
  • Nagru87
    16 posts

    @ubi-woofer thx at lest some good news 🙂

  • Kanjozoku_96
    1 posts

    @ubi-woofer Due some reason I can't update my window to the latest version , so please ubisoft release some patch regarding this issue, I dont wanna format my pc becoz of this matter, I had no problem plying other assasin creed game

  • refan7
    3 posts

    Experiencing the same thing here. Updating Windows 10 to a very specific version not an option due to work related constrictions.

    I hope Ubisoft will fix it at some point. It's been a month since the occurrence was first reported (on launch) and the game is still unplayable.

  • refan7
    3 posts

    Oh, right, let me go ahead and post my system specs for troubleshooting purposes and to possibly allow their team to pinpoint and replicate the issue.

    GPU: GeForce GTX 1060 6GB
    CPU: i7-6700 3.4 GhZ
    RAM: 16 GB
    Nvidia Driver: 457.51
    Windows 10 Pro of 2016

    The flickering is exactly as shown on the photo of the post. It is multi-colored and affects smoke effects caused by the fire (that would be the candles and torches in the very first scene of the game). You see it in the very first room you start the game (if you look to the left or right). If you take a few steps forward and go through the door it gets even worse. It's panda-bear-flicker-madness at that point, so I have to turn off the game.

    These flicker effects are so widespread that the game is completely unplayable. Personally, I couldn't take more than 20 seconds of that.

    I do hope the Ubisoft team would take this problem seriously. I've tried altering the presets to the lowest setting but it did not help. I tried running the .exe file in all sorts of compatibility modes but it did not help.

    It is the first time I see this effect happen on any game so my ideas of fixing it are not vast. Hopefully Ubisoft will release a patch to address the occurrence.

  • Starcadian
    7 posts

    @refan7 With the latest patch, the game won't even launch past the menu for me, 980 GTX, 32GB RAM i7-6700K CPU. Meanwhile it runs on my surface book 2.

    They essentially had the wrong minimum requirements and that's just not cool.

  • vahndaar
    130 posts

    Tried it again after 1.0.4 and it's still running like hot garbage and I'm still convinced that it's to do with fire/smoke/particle effects tanking frame rate. Likely also why antialiasing is tanking performance as well. Guys this is the same bug that Origins suffered from, exactly the same thing happened there as is happening here, fire would tank frame rates and chew up GPUs for no apparent reason. This was patched out in Origins and it's now back again.

    The Quebec team had Odyssey running perfectly and it looks and runs way better than this. These bugs are on the engine build that Montreal are using and have existed since they put out Origins.

    Also never in my life have I seen a game requiring a specific windows build. The latest windows build and the one you are requiring people to have is in a phased rollout so not everyone will get it automatically. You can force it by downloading the installation media and running it from that.

    There is something fundamentally flawed here when PCs with considerably more GPU and CPU power than consoles are sitting around half the equivalent performance. Turning down settings also makes hardly any difference. All this suggests an issue within the renderer itself. It's not optimisation, this is a bug, there is something not working right in the code.

    The visuals look worse than Odyssey yet frame rates are all over the place and I'm struggling to hit 60fps at 1440p on a 2080ti despite hardly any visual complexity onscreen. It's just inexplicable.

    If this continues beyond the next update then I'm going to seek a refund and will come back to this in six months when it's on sale and hopefully been fixed.

  • MrUnlucky00
    1 posts

     Effects such as fire, smoke, fog, mud-snow particles are disrupted in the game.  

  • refan7
    3 posts

    @vahndaar Right, it's just disgraceful at this point. The game is ridiculously badly optimized, riddled with gameplay bugs (of what I read, since I can't actually play the game at all due to the flickering of the smoke), and seems like it's in alpha state, not even beta, let alone release.

    It seems that rather optimizing their game, they just upped the system requirements and left it as is. But even so, choppy framerates are all over the place, even on high performing machines. Nobody is spared [insert Ubisoft evil laughter here].

    Good luck with the refund request, mate. I opened a ticket 4-5 days ago with no response from the support still. It's like they are non-existent. I've seen guys mentioning that they've been waiting for 2-3+ weeks and still got no response.

    The game would have been slaughtered and absolutely demolished on the steam comment section. Ubisoft must have known fully well what unfinished product they release because they released it on the two platforms where there is no comment section at all - Uplay and EpicGames (and avoided all others carefully).

  • vahndaar
    130 posts

    Yeah, and for reference In Athens in Odyssey which is arguably the most complex the game get visually the frame rate hovers around 70fps. In Valhalla in the first town in Norway, can't remember the name of it but it consists of a longhouse, a few structures and mountains I'm getting 40fps for the same settings. The game is spending a lot of GPU time doing not a whole lot. I don't know if it's scene management, occlusion culling, or wonky fire and smoke code but it's just not right.

    You're absolutely right that instead of fixing the problem they'll likely just increase the hardware requirements. This needs vulkan because the DX12 implementation here is dreck. RDR2 runs way better for massively superior visual fidelity so this is absolutely coding and optimisation related.

  • vahndaar
    130 posts

    I've exhaustively tried tinkering with all settings but nothing makes any difference, between ultra and low settings the difference is about 10 fps.

    Here is an example - all settings on their lowest possible and the GPU is pegged at 90%+ utilisation for virtually no graphical complexity.

    Basically one of the simplest scenes in AC Valhalla is running worse on low settings than one of the most complex in AC Odyssey on Ultra settings. This needs sorted!!

    Yes, it's 3440 x 1440 and yes it's running at 75 fps but I've pasted in an equivalent image from AC Odyssey for comparison:


    For reference, in AC Odyssey, on max settings, 75fps @ 3440 x 1440 for 92% utilisation:


  • vahndaar
    130 posts

    Just adding AC Origins as well for reference. Max settings, 3440 x 1440. Again, runs perfectly at 75fps for 90% utilisation in one of the most complex scenes.


  • Thanhvu96
    7 posts

    Still no fix after update, should I just give up hope on them ever going to fix this bs bug....

  • Calebe_Farias
    3 posts

    Estou com este mesmo problema também

  • Nikishkin200
    1 posts

    1080 GTX
    Windows updated - didnt work for me

  • Liverpaul90
    1 posts

    Hello, so is there any fix now apart from updating Windows? Because I just bought the game and it is 1,5 months after release, and I am also having this bug because though I have the latest version of windows and my graphic drivers ...

  • RedRevil
    1 posts

    Still no fix. Issue persists in all 3 games: Origins, Odyssey and now same crap with Valhalla. Embarrasing

  • Dreddmartyr
    2 posts

    Having the issue on GTX 1060, driver 460.89.
    After reinstalling windows and updating everything, including game ready drivers, I'm suddenly getting this issue. Played over 20 hours so far and all of a sudden, getting this problem. I would assume this is a priority issue that should be addressed in the next update.....?

  • Thanhvu96
    7 posts

    I caved and update windows. It works but really not worth the time (takes me 2 days to do the update and fix everything).

Suggested Topics