ubisoft forums

Quick Suggestions

  • CrazyDonkey88
    100 posts

    @charleye30 lucky you i still can't get rid of error message in ubiconnect

  • EDAMl
    2 posts

    @charleye30 i have the same gpu and half the ram with a r7 3700x and have the same exact issue you face.

  • Dalver
    1 posts

    Same with me, game won't start after splash screen. But I am completely different than everyone else. Because I've played it for 3 days without a problem. Last night I turned off the game and today it doesn't start anymore. I have updated everything and still nothing. I have gone back to an earlier windows safety point. Still doesn't load. I have all other AC games and all of them start as normal and play, I have checked every last one. I have also checked all far cry-ies just to be sure. All of the far cry-ies work also but for valhalla. Basically all the old ubi games still work, but not valhalla. Valhalla just doesn't want to start anymore. I have Valhalla installed in another drive than ubiconnect and my system, but that shouldn' be it because it has worked for 3 days and I have played valhalla several hours, several times.

  • narot23
    7 posts

    @dalver I had the exact same issue. Last night the game launched fine, I did some benchmarks and tuned my settings. When I went to play around 11am this morning the game just took a dive and I've been on the splash screen train ever since. I'm wondering if they did a hotfix or a small patch that's causing the issue? I had no issues last night.

  • Devo1dHero
    1 posts

    I installed the game and launcher on the same hard drive and it still wont load. Do i really have to put it onto the same drive I put windows on?

  • Andrepisa89
    9 posts

    I have also the same problem, I have installed the game in the same folder of Ubisoft and in windows. It’s a shame.

  • CrazyDonkey88
    100 posts

    @andrepisa89 yeah, nothing changed so far. [censored] ubisoft

  • mahhnameehh
    1 posts

    @frostizy what do i do when i install hardlink?
    i extracted it and all i get is a bunch of folders there is no application

  • CityofOne
    1 posts

    After trying everything else, uninstalling, reinstalling, updating everything, and numerous other unlikely things suggested by tech support, I found out that the game won't launch from NVME drives (or at least mine). I know some people were saying they got it to work by moving it to their windows drive, but I didn't have space so I copied my installation over to a SSD I had and the game launched just fine.

    So if your game is installed on an NVME drive, try moving it to something else... Or, maybe just a different drive regardless. Still not sure why though.

  • emmaj95
    66 posts

    @cityofone Ive tried it on an NVME, an SSD, and an HDD drive with no luck 😞

  • Symoris
    1 posts

    Do you use a windows insider version? If so you have to roll back or go to the standard version.

  • pixxle85
    2 posts


    have exactly the same problem and Ubisoft shut down the whole support page...lol.
    No live chat and no possibility for ticket creation!!

    I tried all work arounds but nothing helped for me so far...first after 5 years i bought a release game and than this....

    Tried so far:

    • symbol links to videos and sounddata
    • updated all drivers and windows
    • VC redist update
    • start as admin
  • BulletMagnet187
    1 posts

    I'm also stuck at splash screen. I can leave it for 10 minutes and come back and it will still be stuck there. I can however launch and play the game through Amazon Luna but definitely not through ubisoft. Games and ubisoft are installed on the same ssd as my o.s.
    R7 3800x
    32gb 3.2k ram
    Rtx 2070s

  • Hometimebill
    1 posts

    Game seems to load fine. I get Seer cutscene then ... either black or white, no loading rededuls, and a sound loop. Uninstall/ Reset many times over. help please I just want to game?

  • Jambo165
    1 posts

    Solution that worked for me, but YMMV - navigate to the folder you installed AC Valhalla and launch ACValhalla.exe directly. Create shortcut from this file if you'd like to access it from your desktop. Had the same issue as many here where I couldn't get the game to launch past the 'Ubisoft Connect' splash window. The game itself never even launched.

  • mmZi
    1 posts

    @cityofone game not on nvme disk helped for me.
    i moved a game to non nvme disk, opened ubisoft launcher, and selected "find installed game".

    Gamers rule, ubisoft and their support is very bad, i'm ok if it was release day trouble, but its already 13 days after!

  • Vp.zanjiri
    1 posts

    i fixed the game with linkshell
    but what should i do if game get a update ? can i update the game with linkshell state?

  • DarthZed13
    4 posts

    So, does anyone have the address and billing information for Ubisoft since I'm now doing their Tech Support work for them? I hope they knew the price I charge per minute doing this kind of work.

  • apolek_gaming
    5 posts

    @troykt76 I know this is a bit late, but I fixed this simply by running the exes in the ubisoft folder as admin with disabled fullscreen optim.... Hope that helps somebody. 🙂

  • Ubi-Mark.
    Ubisoft Support Staff 3006 posts

    Hello @apolek_gaming,

    Thank you for sharing this with our community! We're glad that this issue has been resolved for you! We usually recommend running applications as Administrator, as this can eliminate any potential software conflicts. Additionally, we also recommend going through these steps as well 🙂

    Official Response

Suggested Topics