ubisoft forums

Quick Suggestions

  • JeppeND
    1 posts

    Hello Ubisoft support.
    I'm still, even after update 1.1.1, experiencing the same performance and optimisation issues that all happen at once when they happen.
    The issues that all happen at the same time are:

    • Eivor and all objects in the game freezes, but you are still able to move the camera and then the save icon in the lower right corner spins around until the freeze is over (how long the freeze lasts is very different from time to time).
    • Background of all sub menus (inventory, skills, main map, abillities, the order etc.) in game menu becomes black but you can still see all icons on the main map.
    • All icons in HUD wheel for calling mount, viking ship etc. becomes invisible.

    The time these issues last are as mentioned different for each time.

    My PC specs are:
    Intel(R) Core(TM) i7-8086K CPU @ 4.00GHz  4.01 GHz
    16,0 GB DDR4 RAM
    GTX 1080 Ti

    Apart from the mentioned issues my PC runs the game perfectly with a high frame rate on ultra settings all the time which should be expected from the mentioned specs.
    I do have the latest NVIDIA driver update and also the latest Windows 10 update. I have also tried to disable my firewall and antivirus. And I also did memory optimization on my SSD in advanced system settings on Windows. But no luck fixing these issues. Any suggestions or work arounds? Or will you please look into these problems for a future patch?

  • Ares_SE
    1 posts

    So bought the game yesterday. Spent 2 hours troubleshooting according to the normal text book procedures.

    • It takes 1-2 minutes to even load up the game. Then another 45 seconds "checking for add-ons".
    • The game is laggy in the main menu.
    • When I start a new game, it's just not playable in any way as it's so slow.
    • I tried to do a benchmark test but that makes the game crash or stop responding.
    • I tried to lower graphic settings to medium then low without any result.
    • Tried all the steps in your troubleshooting guide /deleted temp files, updated all drivers (of course), ran msconfig to turn off all non essential processes etc, etc Even turned off all network connections, disconnected all Bluetooth and other troubleshooting stuff one might think of).
    • Running from an SSD hd

    I can run Cyberpunk and Farcry 5 without any issues at high graphical settings. Have had no issues ever with this rig at any point, ever. 

    Specs below.

    System Information
       Time of this report: 1/23/2021, 00:49:52
           Machine name: DESKTOP-920KIK9
            Machine Id: {134CF811-667A-4A80-A3B5-A0C713566537}
         Operating System: Windows 10 Pro 64-bit (10.0, Build 19041) (19041.vb_release.191206-1406)
             Language: Swedish (Regional Setting: Swedish)
       System Manufacturer: Alienware
           System Model: Alienware Aurora R6
               BIOS: 1.0.23 (type: UEFI)
            Processor: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz (8 CPUs), ~3.6GHz
              Memory: 32768MB RAM
       Available OS Memory: 32672MB RAM
            Page File: 11449MB used, 26085MB available
           Windows Dir: C:\WINDOWS
         DirectX Version: DirectX 12
       DX Setup Parameters: Not found
         User DPI Setting: 96 DPI (100 percent)
        System DPI Setting: 96 DPI (100 percent)
         DWM DPI Scaling: Disabled
             Miracast: Available, with HDCP
    Microsoft Graphics Hybrid: Not Supported
     DirectX Database Version: 1.0.8
          DxDiag Version: 10.00.19041.0546 64bit Unicode

    DxDiag Notes
       Display Tab 1: No problems found.
       Display Tab 2: No problems found.
        Sound Tab 1: No problems found.
        Sound Tab 2: No problems found.
        Sound Tab 3: No problems found.
         Input Tab: No problems found.

    DirectX Debug Levels
    Direct3D:  0/4 (retail)
    DirectDraw: 0/4 (retail)
    DirectInput: 0/5 (retail)
    DirectMusic: 0/5 (retail)
    DirectPlay: 0/9 (retail)
    DirectSound: 0/5 (retail)
    DirectShow: 0/6 (retail)

  • Back4Breakfast
    1 posts

    I just re-signed up for Uplay+ because I wanted to play Valhalla, and it would appear this was a grave error of judgement. The game looks amazing, shame it doesn't perform anywhere near where previous AC titles did. I've read about 100 Reddit posts, people with worse specs than me and much better specs than me, all saying the same thing. It starts well, then you get dips and freezing, and nothing seems to fix it. I've completed the following tasks:

    - Latest Nvidia Driver installed with clean install option
    - The install is fresh from yesterday (29/01), so verifying files seemed a bit pointless, but it is done
    - Running the game at High, very slow
    - Running the game at Medium, still slow
    - Running the game at Low, still slow and practically insulting to the spec of the machine
    - Turned off all background services that I could
    - Turned off all startup applications that I could except the essential services to Windows
    - OS is up-to-date
    - Ubisoft Connect is up-to-date 
    - Benchmark ran at High, Medium and all report drops when moving through sprite filled areas. Low has the odd drop, but the game just looks poor.
    - Capped the framerate to 60 FPS
    - Field of View reduced to 90%
    - Resolution reduced to 90% (this made the game blurry so I put it back up, can't play it thinking my eyesight is at fault)
    - Run the executables as Administrator (this doesn't actually work as when you say yes to the elevation, it just hangs so I turned it off)
    - Installed a secondary page file on the same disk as the game

    I've also tried some of the more advanced items people posted, such as disabling exploitation on the Vahalla executables. I've also explicitly told the Nvidia driver and Windows to always use the Nvidia card at full power consumption whenever the Vahalla or Vahalla Plus executables are running.

    I've run all sorts of combos, even down to LOW and it still isn't great. I'm running an i9 9900 with a 2080 RTX on an SSD. It really isn't my hardware as none of the other Ubi titles I've played have ever had this problem. If anyone has any other blinding ideas on how to fix this problem, I'm all ears!

    Many thanks

  • Yesin069
    554 posts

    Since I updated to Title Update 1.1.2, I started having frequent crashes. I didn't play that much before (currently I am at 25% progress), but I never had any crashes (just one which was related to NVIDIA drivers and fixed by NVIDIA). Those NVIDIA crashed were also hard crashes which let my whole PC restart, so I stopped playing until NVIDIA fixed this with new drivers.

    Since the new update I get crashes in every play session and they are just random. Sometimes I play for hours with no crashes and sometimes they happen all 20 minutes or so until I stop playing because of the lost progress.

    Those crashes just crash the game and don't restart the whole PC. It seems really likely that the new update is the reason behind those crashes.

    Does anybody here also experience those crashes - especially since the new update?

  • Dasher222
    19 posts


    My game is constantly crashing now. Can't access the river raids at all without the game crashing immediatly, spend more than a couple minutes stacking stones and get a crash. Who knows what else will crash it.

  • BlackLord049
    7 posts

    @dasher222 it seems that we are a lot facing crashes : https://discussions.ubisoft.com/topic/78181/ac-valhalla-crashes-every-15-30-minutes

    Some days the game can be played during an hour or two without a crash, sometimes it will just crash 3 times in a short interval. Whatever the driver version you're running, whatever the result of any stress test you will run (obviously positive by the way). The same happens with WD:Legion, and finally it's a common behavior for those last two Ubisoft games.

  • jjuliusr
    1 posts


    I'm having issues in AC Valhalla where after about an hour I get stuttering where the frames drop from average 90 FPS to average 83 FPS with drops of 4 FPS.
    I managed to capture a screenshot where you can see it change.
    I found a temporary solution where another user said it's linked to Ubisoft Connect and disabling it solves it, but this keeps me out of achievements, events and the store.

    is this there another solution to solve this?

    Thanks in advance.

  • aronin7
    1 posts

    @ubi-spud Hello and good evening. I am experiencing a similar issue. I am running on a Nvidia 2070, 10th gen intel i7, and 16gb ram. The game runs perfectly smooth at 60-80 fps with no dips for about 10 minutes. I have done a clean uninstall/ reinstall twice, verified the files, verified all of my drivers are up to date as of 3/26/21 and the game still crashes, without fail, in under ten minutes without any frame rate drop, glitching, etc.

  • gorpybleeder
    1 posts

    After messing around with settings etc. for days and getting extremely frustrated, I finally found this forum post and did everything the Ubisoft Support person said. Uninstalling and then reinstalling the Ubisoft Connect app seems to have fixed the issue for me. Getting a steady 55-60 FPS at 1440p now on Medium settings with a 1070. Fingers crossed this works for good - as I have yet to play longer than about 20 minutes or so - but the difference is night and day right now.

  • RitzPaul94
    41 posts

    I am done with this [censored] game they have released so many patches but did not fix the performance instead the release new cosmetics these [censored] [censored] never fix the performance problems in games. And this is what they wrote in their troubleshooting guide " Assassin's Creed Valhalla has been optimised to run as fluidly as possible" This game runs like [censored] fps drops stuttering it doesn't matter if you lower the settings you will get the same fps high - very high. UBI [censored] [censored] if you can't fix your game just fix your refund policy which is more [censored] up than your game. And if you are wondering about my specs here rtx 2060
    ryzen 5 3600 16gb ram wd blue ssd
    Even cyberpunk runs better than this garbage.

  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Hello there,

    I apologise for the delayed response. I'd like to reach out to you all with an update.

    The development team has deployed a number of fixes for performance and optimisation issues on PC, particularly within TU 1.3.2. We will now be marking this thread as "Resolved." Additionally, as there have not been any reports shared within this thread for some time, we will now be locking this thread.

    If you are encountering any issues with performance and optimisation whilst playing Assassin's Creed Valhalla, we first invite you to check out our "Reported Issue Megathread List." This list has several ongoing investigations already linked, which may match the technical issue you're encountering. If you see a Megathread which matches your issue, please can you share your report within that thread?

    If you are unable to find a Megathread that matches the issue you're encountering, please don't hesitate to create a new thread so we can take a closer look. Please include as much information as possible about the technical trouble you're experiencing, as this will be helpful for further investigation.

    Thank you 🙂

    Official Response

Suggested Topics