ubisoft forums

Quick Suggestions

  • FlomTTV
    1 posts

    @ubi-keo I encountered the same bug today. Is there any progress or should it be resolved already? my NPC is missing, too

  • Ubi-Keo
    Ubisoft Support Staff 6336 posts

    Hi @flomttv and welcome to the forums.

    I'm sorry to hear that you are also experiencing issues with the quest 'The Twit Saga Part 2'.

    I can confirm that the development team are intending to fix this with a future update, however we have no ETA on when the update will be released.

    Please keep checking the known issues list and the news and announcements page for updates.

    Official Response
  • Ubi-Supportski
    99 posts

    Hey @ninja69xt @davidnestico

    Sorry to hear about that!

    As this mystery is a part II of The Twit Saga, you need to do the first part of the mystery to have the NPC spawn for the Part II. The first part of the Twit Saga is in Ledecestrescire. 
    Can you please check if that was done?

  • MarkThis9
    1 posts

    @ubi-smash This glitch is still present so many months later. I have carried the brother, fought off attackers and yet the NPC just stays there permanently, not interacting/finishing the task. He is still there when I restart the game another day. This is the only England task that remains for me to complete!

  • JDP3D
    3 posts

    The prisoner that is meant to be freed at this location is not appearing and therefore I cannot complete this event. This is on PS5 with all latest patches applied.

  • Ubi_Plush
    364 posts

    @jdp3d Hello. Sorry to hear about this mystery not completing. The game team is also aware of the issue, and this bug should be resolved in a future patch. However, I'd like to clarify if you have completed part 1 of the mystery in Ledecestrescire. If so, would you post an image of your map over this location?

  • markangelolicup
    1 posts

    @markthis9 i was having this same glitch. After putting down the brother and fighting the bandit nothing happens. I just wait for maybe 5 minutes and the speak icon appeared on the brother. I was able to complete the quest. Try it.

  • Ubi-Oxavo
    805 posts

    Hello @jakhi147 and thanks for letting us know that issue has been solved for you after reloading, happy to hear that!

    Hey @MarkThis9 , I am sorry to hear the issue still persist for you. Have you tried the workaround provided by @markangelolicup , did it work for you? If no, could you please record the video of the issue, upload it on any hosting of your choice and send us the link so we can investigate?

    @markangelolicup , thanks for your input, we appreciate it.

    Please let us know if you have additional questions.

  • Areen__
    2 posts

    I can't start the conversation and I can't carry the other brother 🥲 I finished part 1 and did everything.
    this bug is so frustrating I've tried everything nothing works ☹💔 please fix it its the only thing between me and the platinum trophy. I really don't want to start all over again

  • Ubi-Viral
    2366 posts

    @areen__ Thank you for your reply and for letting us know that you are also experiencing this issue. Would you be able to share a video with us that shows this issue happening, we can then use this in our investigation with the game team.

    Thank you.

  • Areen__
    2 posts
  • Ubi-Gizmo
    Ubisoft Support Staff 2297 posts

    Hey there @areen__, thank you for taking the time to share this video. I have forwarded this information over to the development team. The team believes this bug should be fixed in an upcoming patch, and once that patch is released, more information will be posted in the News and Announcements section. Let me know if you have any questions!

    Official Response
  • Ubi-Froggard
    Ubisoft Support Staff 4056 posts

    Hey everyone,

    The issue in the quest "The Twit Saga Part 2", where the NPC you are supposed to rescue from the camp is nowhere to be found, should be be resolved in the update today. The patch notes can be found here.

    If anyone still has the issue, please let us know again on here.

    Official Response
  • guest-s9m3baGF
    2 posts
  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Hello there @guest-s9m3baGF! Welcome to the forums 🙂

    I'm sorry to hear that you're unable to progress in "The Twit Saga Part 2" following the release of TU 1.5.0. Thanks for taking the time to share a video with us.

    Just to confirm, have you been able to complete the World Event "The Twit Saga Part 1" as well? You can find this World Event in Ledecestrescire. If you haven't yet completed the first part of the saga, you might not be able to start Part 2.

    If you're able to share an additional video which shows the following, that would be helpful for further investigation:

    • That you have the latest Title Update installed on your platform. You can check this in the bottom right-hand corner of the main game menu.
    • That you have completed "The Twit Saga Part 1." You can do this by showing us that you have completed all World Events in Ledecestrescire.
    • That "The Twit Saga Part 2" still doesn't activate when you at the World Event starting location. Please show this on your in-game map.

    We can then include this video in your report to the dedicated teams.

    Thanks! 😊

    Official Response
  • guest-s9m3baGF
    2 posts

    @ubi-borealis Yeah, I was just about to delete the video because common sense came back to me a few days ago and I completed part one. Thank you for responding though!

  • Ubi-Mark.
    Ubisoft Support Staff 3006 posts

    Hello @guest-s9m3bagf,

    Thank you for the update! We're glad that you were able to complete part 1 already! Happy gaming!

    If you're still unable to progress further for any reason, feel free to update this thread and we will be more than happy to assist!

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Hello there!

    As we have had no reports of issues persisting in "The Twit Saga Part Two" following the release of TU 1.5.0, we will now be locking this thread.

    If you encounter any trouble in "The Twit Saga Part Two," please feel welcome to create a new thread and our team will investigate further. When creating a new thread, please ensure that you include a video of the issue you've encountered, as this is helpful for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics