ubisoft forums

Quick Suggestions

  • 26 Likes/881 Replies/53285 Views
    Ubisoft Support Staff 1534 posts

    Hey @Thomsegregore, thanks for getting in touch and sorry to hear about this, as I fully appreciate how difficult it can be to deal with this after you waited to play it.

    First and foremost, for troubleshooting purposes, can I ask you to try completing all of the steps mentioned in the following article, and see if it helps.

    Keep us updated!

    Official Response
  • Don_BelIie
    6 posts

    @bellaende I've got the same thing. 1st install worked like a charm, closed the game and got the oops far cry 6 has crashed. Reinstalled several times and every time I got the same crash dialog. Got it working once more after 4 fresh installs.
    Got a funny workaround for you. Just keep spamming the play button and clicking away the send crash report as fast as you can and after a few tries it will fire up. Sometimes even with the crash report open LOL. Ubisoft outdid themselves once more. Also @Ubi-Borealis <- First one I saw in this post, tell Ubischoft to get their [censored] together, this is the most laughable launch up to date. How the [censored] can you ship out this [censored] where you click play it sends a crash report and if you follow all your stupid braindead steps to 'fix' the problem does not get you anywhere, your troubleshooting page is the most basic steps one can do. And the only workaround is spamming play in the hopes that your [censored] is going to launch anyway.

  • lovableapple
    3 posts

    Same issue here, the game crashes on launch after the splash screen comes up, I've tried everything listed on this thread and others, my PC specs are above the minimum required, (Win 10, 1080ti, 32gig ram, i7 8700k, updated all drivers etc) tried launching in different resolutions and as admin, nothing works

    devs please fix this

  • Marissi125
    1 posts

    trt > Freeze > Crash. I preorder it for 60€ and cant play what the fk is this ?!?!

    by me too

  • SirNasso
    1 posts

    Launched the game, went into settings. And as was looking into them and tuning some of them I got a BSOD. After restart, launch the game and as soon as the menu appears I get the same IRQL_NOT_LESS_OR_EQUAL BSOD. So the game is not playable at all. I'm in Bulgaria and have i7-10700K and RTX3070. ALl drivers updated.

  • Ubi-Mercury
    619 posts

    Thanks for the update @duckers_mcquack! I'm glad to hear that you were able to play your game successfully now. If you have any other questions, don't hesitate to let me know, and I'd be glad to help! 😁

  • OptionalLemon
    1 posts

    I was able to launch the game exactly once. I played through the short intro sequence, quit and now when I try to launch the game I cannot get past the launcher splash screen. I don't see the "Warm up PSO chache" message anymore either. The launcher simply quits quietly without any error messages. I have tried the advice given here in this topic. None helped.

    Windows 10 Pro
    RTX 3080
    32 GB Ram

  • Likato
    3 posts

    @ubi-karl Steps ??????????

  • raaskeen
    4 posts

    Has anyone been able to launch the game yet ?? my problem is still the same "unable to start the game, your GPU may not be compatible with the game or your driver version is outdated. please check video adapter or update your drivers"

    I have the latest driver updates and windows updates...
    Windows 10 Pro
    NVidia Geforce GTX 960
    8G ram

  • Sgt_Drakelaw
    1 posts

    @Ubi-Mark I cannot launch the game, it crash at startup, everything is up to date and I cannot even submit a ticket to the support because even the support website is broken. Ive tried everything : uninstalling reinstalling, verifing files, closed all application, etc ..
    Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz / GeForce GTX 760
    Im very close to ask for a refund, it's not normal for a "finished" game to have that kind of problem

  • SEEK68
    3 posts

    @ubi-mark Hi I encounter same issues, game icorrect installed, files are verified, started the game as admin, nothing works and the game doesnt start, any suggestion?

  • Mr.Creationeer
    3 posts

    Suffering the same problem and all those "steps" have been done. They're the typical "make sure drivers are updated and no background anti virus is causing problems" stuff.
    The game doesn't provide any kind of dump to show where the error is, it's working and then desktop. You could alt tabbed out and the game will randomly die on it's own too. Doesn't seem to be a specific player action causing it. I think it might be the cloud sync, going to disable it and see if that helps. I'll update later after testing.

  • p4n1sh3r
    10 posts

    I was able to play until the beach after the intro then the game closed and I got the "unable to sync achievements" error. Now it seems to run again with starting as admin.

  • PvtCustard
    1 posts

    This is as far as I get. Currently an hour in, and nothing.

    And no, I don't need the bot response, asking me to do all but re-write the game for you. Apparently a 5800X / 3090 FE / 32Gb of DDR4 4000mhz memory, isn't quite what's required!

    Maybe you guys could try, just for one day, to not be UbiSoft!!

    EDIT : Oooohhhh, update, it did something. Unfortunately it was activated yesterday you utter toolboxes!

  • zboq
    5 posts

    I have exactly the same problem. Game starts, I can play for a while a then quits to desktop.
    I'm pretty sure that every time it quits, I get the error about achievements cannot be synced.
    I've already tried some steps like updating drivers etc... but nothing helps.

    My config is Lenovo Legion 5 with i7 and RTX2060.

  • p4n1sh3r
    10 posts

    @p4n1sh3r Have to correct myself. I was just lucky and now I'm back to the "unable to sync achievments" error - so starting as admin makes not much differences.

  • Ubi-Nacho
    Ubisoft Support Staff 1736 posts

    Hi there @Mr-Creationeer

    If you've tried all of the steps given, and you're testing with cloud sync disabled, let us know how it goes! If the issue persists, could you try setting Ubisoft Connect to offline mode and see if this has any impact?

    Hey @zboq

    Were you able to try any of Ubi-Karl's steps for troubleshooting? This will help us rule out some common causes. Could you also test the game with Ubisoft Connect in offline mode?

    Thank you.

    Official Response
  • Hank-1983
    2 posts

    #metoo Having the same issue as everybody else. Have spent 16 hours today infront of the screen and tryed everything. Im thinking about suicide now 😞 Please fix it Ubisoft.

  • ScoobyDrew74
    2 posts

    Don't Rush guys as soon as you get it to launch the game will crash randomly back to desktop from every 5 mins to every hour at any time in-between for no reason.. doesn't give error code nothing.. then you try to relaunch and there is another bunch of issues...this could be the next biggest flop next to cyberpunk.. oh dear oh dear

  • raaskeen
    4 posts

    @scoobydrew74 Atleast u've played it......

Suggested Topics