ubisoft forums

Quick Suggestions

  • 1 Likes/109 Replies/4026 Views
    8 posts

    I apologize I don't understand what you mean.
    I close Ubisoft Connect (I presume) and then jump out of what to try what?

  • Ubi-Nacho
    Ubisoft Support Staff 1736 posts

    @maximumecho Thank you for bringing this to our attention.

    I'll make sure that the team knows this is not a issue that only affects Ubisoft+ members, and is impacting other players too.

    Apologies for any inconvenience caused.

    Official Response
  • dichterDichter
    2 posts

    try this: uninstall anno, close ubi connect, clear cache, open ubi.
    then in the store, scroll down a bit for the free weekend. choose pc download and there appears a free play button.

    it worked for me now to start the download of the game again and i got the message that it was added to my lib. we will see.

  • Bright_One
    36 posts

    @reinstenvaag ,
    I understand your frustration , I am equally frustrated , but I do not think that it's such a good idea to do headless acts such as destroying everything else because of frustration over one single game (not meant to offend , I am just saying) .
    This appear to be a problem with Anno 1800 and it makes UBI Soft look like amateurs .
    My suggestion is that you , your son , your nephews and your fiance all play some other game(s) until UBI Soft got their act together again 🙂

  • Subtropic1
    2 posts

    you are absolutely right, Ubisoft are amateurs - the best example

  • Gohan022
    1 posts

    @schluppine me too

  • Xx9mmPreacherxX
    2 posts

    @manisc09 Same Issue here, can't load game.

  • MEF2A
    1 posts

    Me too. I tried removing the cache, reinstaling Ubisoft Connect, restart computer. I don't want to buy the game if the free trial doesn't even work. Too much of my time wasted trying to troubleshoot this thing.

  • Takamori_Fox
    1 posts

    @mendoza2686 Yep same issue here.

  • ReinStenvaag
    6 posts

    I think part of the issue.. is people are mixing issues.
    Some say the game keeps crashing on start. Thats one issue.
    Some say they need a game key to access it. Thats a separate issue.
    Ubi+ subscribers, who were playing the game already, and have been locked out of the game entirely since the free weekend was announced, is another totally separate issue. (And incidentally the one I've been posting about for 24 hours)

    If we mix these issues too much, then Ubi doesnt know exactly what to look for, to fix all of them. They will fix one, and think it fixed all of them.

  • Armadill0
    5 posts

    Still the same error that the "product cannot be activated right now".

  • Smiter02
    1 posts

    @schluppine same here

  • ane50ena
    1 posts

    @schluppine So do I.
    I might want to mention, that I used Free Weekends of Anno 1800 in the past.
    There, you always downloaded a Free Weekend version of Anno 1800.
    This time however, pressing download instead seems to download the actual game, which I then obviously can´t play.

  • MaximumEcho
    8 posts

    Same here, now the error I see is this:

    Which is slightly different than what I was getting before. It still does not work.

  • konnsky00
    2 posts

    Its been two day, and I still cant play Anno 1800. Soon there will be NO FREE WEEK left...

  • Bright_One
    36 posts

    I am just so happy this moment that UBI Soft never lured me into buying the game , not even with discounts.
    I were a Beta participant and were not that pleased with that. But I wanted to try the Free Weekend play to see how far the game has progressed (or regressed as it may be) .
    However , not even being able to play for free I am so happy that I did not pay and then not be able to play ! , just saying !

  • konnsky00
    2 posts

    @bright_one yeah this is really sad, I wanted to buy it since its really cheap right now, but I cant even play it and Ubisoft seems to be doing nothing to fix the situation...

  • aabreur
    9 posts

    Hi there dude :),

    The workaround provided on this link does not work for ubisoft+ subscribers, current behavior is:

    • 500 MB patch / 11.x -> Game can be launched (no HighLife)
    • 2.9GB patch / 12.0 -> Game cannot be launched. "This product cannot be activated right now" in all attempts.
  • MaximumEcho
    8 posts

    Restarted Ubisoft Connect, automatically received a 227 MB update for Anno 1800.

    The game (Free Weekend version) is now launching.

  • aabreur
    9 posts

    seems fixed now !!!

    277.50 MB patch FTW

    Ubisoft+ subscriber here. Game succesfully launched, v12 on, HighLife DLC on!!

    Thanks to the ones that worked hard on this fix 🙂

Suggested Topics