ubisoft forums

Quick Suggestions

  • 17 Likes/137 Replies/7229 Views
    2 posts

    unable to finish the trails of morrigan in ulster. ive done it a few times still not done. stopped playing came back a few days later and still not able to. ive progressed jnto the ireland story more but still not done.
    first time playing through the dlc.

    me completing it but it not actually being counted

  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Hello there @Buldozair92, @XxGODzLIKETTOxX, @Prowler222 & @fawna_wolf!

    Thanks for taking the time to share your reports with us regarding the Trial of the Morrigan at Ulster. I'm sorry that you've been unable to complete this Trial in-game.

    The development team are aware of this issue and they're currently investigating further. We don't yet have any updates to share from the investigation at this time. As soon as we have any new information to share regarding the Trial in Ulster, we will let you know within this thread and in the News & Announcements forum.

    Thanks! 😊

    Official Response
  • fawna_wolf
    2 posts

    @ubi-borealis i forgot to add im also suffering from the modraniht tattoo bug. (i keep getting the tattoo set added to my inventory even though i have long sense claimed it) this bug is no big deal comparatively just moreso annoying.

  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Thanks for letting me know that you've encountered trouble with the Mōdraniht tattoos, @fawna_wolf. We have an ongoing Megathread for this issue, that you can check out here! All information and updates from the investigation into the Mōdraniht tattoos will be shared in that linked thread, so I recommend giving it a follow for all of the most up-to-date news.

    Thanks! 😊

    Official Response
  • MarkyMark_21
    16 posts

    I'm in the same boat as everyone in this thread - Morrigan trial in Ulster can't be finished even after i defeated both druids and werewolfs. Fog just disappeared and mystery icon becomes active again, like i haven't even started it. Please, dear Ubisoft, fix this issue. I would be totally fine if there wouldn't be trophy for 100% completion, but because of that glitch I'm unable to get that trophy, which is really disappointing.

  • Dagger5k
    1 posts

    Can't complete the trial. it sucks because it is the last thing I need for the trophy

  • Ubi-MrM
    Ubisoft Support Staff 4541 posts

    Hey there @MarkyMark_21 and @Dagger5k - a big welcome to both of you to Discussions!

    I am sorry to hear that you are both unable to complete the Trial of the Morrigan in Ulster. As my colleague @Ubi-Borealis stated previously, the investigation into this issue is ongoing and the team are currently investigating. As soon as we have any news to share on the progress of the investigation, we will let everyone in this megathread know.

    To help the team with their investigation, it would be appreciated if you could provide a video demonstrating the issue as it appears in your game, as well as answer the following two questions:

    • Have you previously completed the trial in another playthrough of the DLC, or is this your first time attempting it?
    • Were you in combat prior to interacting with the brazier?

    Thank you both in advance for your help and time! 🙂

    Official Response
  • MarkyMark_21
    16 posts

    @ubi-woofer thank you for your response! It's my first playthrough of "Wrath of the Druids". The video i could provide is the same, as people's posted here earlier. Also, i wasn't in a combat when interacting trial icon.

  • Ubi-TheBerry
    Ubisoft Support Staff 5891 posts

    Hey @MarkyMark_21

    Thank you for getting back to us!

    The team are still working on this and hope to resolve it in a future fix.

    We don't require additional footage at the moment, but should this change or there be any more news, we'll let you know here.

    Official Response
  • if2011
    3 posts

    I’ve finished the trial twice and gotten the XP for it but the logo still stays on the map and isn’t registering as completed for me. I really wanted to 100% the DLC and was wondering if this would be fixed/patched soon?

  • mistress3riple
    1 posts

    I have the same problem on PS4. I finished the trial, got the XP but it doesn't recognize it as finished

  • Mrz_Ghoul
    2 posts

    That mystery in Ulster, don't register in the game, i miss the Conquest all territory of Irland, but i made every time, not sucess.

  • Ubi-Mark.
    Ubisoft Support Staff 3006 posts

    Hello @Mrz_Ghoul,

    Thank you for bringing this to our attention!

    I can see that this issue has been already reported and it's currently being investigated - a fix will be deployed in a future update. Once the resolution is live, we will let everyone know through the patch notes.

    I also merged your thread with our megathread for your visibility.

    If you have any additional questions, please let us know.

    Official Response
  • MarkyMark_21
    16 posts

    @ubi-mark so does it mean that developer team managed to solve that issue and now it's just a matter of time when update will arrive? Thanks

  • Draeka33
    2 posts


    Hi, I'm getting the glitch with the trial North-East of the Ardmel outpost.
    Upon killing the enemies, it looks like my Eivor is a bit drunk for a couple seconds while getting the 700xp (even though my poison resistance is at 77.8, i don't seem to take poison damage).

    However, the trial is still on the map.
    I already turned the map upside down for every single chest (and all that goes for the completion of all territories aside with minor chests on the map) and completed the story.

    The DLC has been out for months, and finishing it is still broken on PS4 !

    May i had that there was a similar problem preventing to complete the main game.

    Even though Ubisoft has been aware about it ("Pig of Prophecy") during the month following the release it it took until the end of April (meaning a period lasting over 6 months during which many couldn't finish it) !

    I loved the game until encountering that cursed pig.

    After it was fixed and first DLC announced, i considered getting it as a redemption chance if that makes sense. What I mean, not broken for months until a fix comes.

    I am really frustrated and discouraged about this cycle of issues repeating all over again. I've seriously considered a refund i doubt I'd get considering it happened doing the last thing I needed (meaning over a day of playtime).

    Now's question time :

    Does Ubisoft intend to fix the DLC ?
    Since I'm here, does the Paris DLC have reported issues preventing from finishing it in it's entirety ?

    To be entirely honest, if it keeps up i might pull back of that franchise if this keeps up.

  • RuLo_FeRReR
    1 posts

    @draeka33 Hi. I can confirm you that the DLC Siege of Paris is free of bugs of this kind. I have the 100% of the throphies and no bugs were shown up. (Ps4 version of the game, played in a Ps5)

  • jurijsele91
    3 posts

    I am in need of assistance. In the dlc "wrath of the druids" i can't complete a one "trial of Morrigan" (northeast of Ulaid). Is an infinite loop, on completion it only gives me experience but the trial remain and therefore i can not complete 100% of the game. I have tried everything even uninstalling and reinstalling the game, but the bug remain and ubisoft support chat keeps telling me it's not available.
    Do you think they will fix this problem?

  • SiLvY199113
    4 posts

    I'm also having issues to complete the trial playing on a PS4 I cleared the whole map and finished all quests only thin g left to do is this trial which can complete over and over for XP but it will not complete.

  • Tikaginha
    1 posts

    @busiestgem77 i'm having the same problem and i already contacted ubisoft and they say the develppers are working on it as fast they can...

  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Hello there!

    I'm sorry to hear that you have encountered trouble when trying to complete the "Trial of the Morrigan" in Ulster. Thank you for continuing share your reports with us within this thread.

    As shared by my colleagues @Ubi-TheBerry & @Ubi-Mark, the development team will be deploying a fix for this issue in a future update! We don't yet have a confirmed ETA for when this update will be released. As soon as we have more information to share, we will let you know within this thread and via patch notes in the News & Announcements forum.

    Thanks! 😊

    Official Response

Suggested Topics